-# Note that this is NOT a relocatable package
%define pref /usr
-%define ver 2.1.12
-%define rel 0
+%define ver 2.5.0
+%define ver2 2.5
+%define rel 1
Summary: The GTK+ 1.2 port of the wxWindows library
Name: wxGTK
Release: %{rel}
Copyright: wxWindows Licence
Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.12.tgz
-URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
-Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-BuildRoot: /tmp/wxgtk_root
+Source: wxGTK-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
+Packager: Vadim Zeitlin <vadim@wxwindows.org>
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
# all packages providing an implementation of wxWindows library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
-# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
Provides: wxwin
+# in addition, we should provide libwx_gtk as automatic generator only notices
+# libwx_gtk-%{ver}-%{rel}
+Provides: libwx_gtk.so
+Provides: libwx_gtk-%{ver2}.so
+
%description
wxWindows is a free C++ library for cross-platform GUI development.
With wxWindows, you can create applications for different GUIs (GTK+,
%package devel
Summary: The GTK+ 1.2 port of the wxWindows library
Group: X11/Libraries
-Requires: wxGTK
+Requires: wxGTK = %{ver}
%description devel
-Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
+Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package gl
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
+Group: X11/Libraries
+Requires: wxGTK = %{ver}
+
+%description gl
+OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package static
+Summary: wxGTK static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
%prep
-%setup -n wxGTK
-./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
+%setup -n wxGTK-%{ver}
%build
-make
+if [ "$SMP" != "" ]; then
+ export MAKE="make -j$SMP"
+else
+ export MAKE="make"
+fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
+$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
+$MAKE
+cd ..
%install
rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
%clean
rm -rf $RPM_BUILD_ROOT
%postun
/sbin/ldconfig
-%files
-%defattr (644, root, root, 755)
-%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-%dir %{pref}/share/wx
-%{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk*
+%post gl
+/sbin/ldconfig
+
+%postun gl
+/sbin/ldconfig
+
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+ ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+ SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
+ SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+ if test "x$SUM1" = "x$SUM2" ; then
+ rm -f %{_bindir}/wx-config
+ fi
+fi
+
+
+%files -f wxstd.lang
+%defattr(-,root,root)
+%doc COPYING.LIB *.txt
+%dir %{_datadir}/wx
+%{_datadir}/wx/*
+%{_libdir}/libwx_gtk-%{ver2}*.so.*
%files devel
-%defattr (644, root, root, 755)
-%dir %{pref}/include/wx
-%{pref}/include/wx/*
-%dir %{pref}/lib/wx
-%{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wx-config
+%defattr(-,root,root)
+%{_libdir}/libwx_gtk-%{ver2}*.so
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxgtk-%{ver2}-config
+%{_datadir}/aclocal/*.m4
+
+%files gl
+%defattr(-,root,root)
+%{_libdir}/libwx_gtk_gl*
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a