]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
new makefiles (part I)
[wxWidgets.git] / wxGTK.spec
index b93582a23ed2eb309cee1738218ef865733a8d18..5dadc5c990f50d84cc5e5be04c67ad2450b35413 100644 (file)
@@ -1,26 +1,43 @@
-Summary: The GTK+ 1.0 port of wxWindows library
+# Note that this is NOT a relocatable package
+%define pref /usr
+%define ver 2.1.0
+%define rel 5
+
+Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
-Version: 2b1
-Release: 1
-Copyright: LGPL
+Version: %{ver}
+Release: %{rel}
+Copyright: wxWindows Licence
 Group: X11/Libraries
-Source0: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK2b1.tgz
-URL: http://www.freiburg.linux.de/~wxxt/docs.html
-Packager: Michael Kiefte <mkiefte@gpu.srv.ualberta.ca>
-Requires: gtk+ >= 1.0.4
+Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.0-b5.tgz
+URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
+Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
+Requires: gtk+ >= 1.2.1
+BuildRoot: /tmp/wxgtk_root
+
+# all packages providing an implementation of wxWindows library (regardless of
+# the toolkit used) should provide the (virtual) wxwin package, this makes it
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+Provides: wxwin
 
 %description
-wxWindows is a free C++ library for cross-platform GUI development. With wxWindows, you can create applications for different GUIs from the same source code. This package also contains a dialog editor.
+wxWindows is a free C++ library for cross-platform GUI development.
+With wxWindows, you can create applications for different GUIs (GTK+,
+Motif/LessTif, MS Windows, Mac) from the same source code.
 
 %prep
 %setup -n wxGTK
-./configure --prefix=/usr --with-threads
+./configure --prefix=%{pref} --with-threads
 
 %build
-make src
+make
 
 %install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
@@ -29,11 +46,14 @@ make install
 /sbin/ldconfig
 
 %files
+%defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-/usr/include/wx
-/usr/lib/wx
-/usr/lib/libwx_gtk_1_0.a
-/usr/lib/libwx_gtk_1_0.so
-/usr/lib/libwx_gtk_1_0.so.1
-/usr/lib/libwx_gtk_1_0.so.1.99
-/usr/bin/wx-config
+%dir %{pref}/include/wx
+%{pref}/include/wx/*
+%dir %{pref}/lib/wx
+%{pref}/lib/wx/*
+%attr(755, -, -) %{pref}/lib/libwx_gtk2.so
+%attr(755, -, -) %{pref}/lib/libwx_gtk2.so.1
+%attr(755, -, -) %{pref}/lib/libwx_gtk2.so.1.0
+%attr(755, -, -) %{pref}/bin/wx-config
+