-Summary: The GTK+ 1.0 port of wxWindows library
+%define pref /usr
+%define ver 2.3.1
+%define rel 1
+
+Summary: The GTK+ 1.2 port of the wxWindows library
Name: wxGTK
-Version: 2b1
-Release: 1
-Copyright: LGPL
+Version: %{ver}
+Release: %{rel}
+Copyright: wxWindows Licence
Group: X11/Libraries
-Source0: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK2b1.tgz
-URL: http://www.freiburg.linux.de/~wxxt/docs.html
-Packager: Michael Kiefte <mkiefte@gpu.srv.ualberta.ca>
-Requires: gtk+ >= 1.0.4
+Source: wxGTK-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
+Packager: Vadim Zeitlin <vadim@wxwindows.org>
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
+
+# all packages providing an implementation of wxWindows library (regardless of
+# the toolkit used) should provide the (virtual) wxwin package, this makes it
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+Provides: wxwin
+
+# in addition, we should provide libwx_gtk as automatic generator only notices
+# libwx_gtk-%{ver}-%{rel}
+Provides: libwx_gtk.so
+Provides: libwx_gtk-2.3.so
%description
-wxWindows is a free C++ library for cross-platform GUI development. With wxWindows, you can create applications for different GUIs from the same source code. This package also contains a dialog editor.
+wxWindows is a free C++ library for cross-platform GUI development.
+With wxWindows, you can create applications for different GUIs (GTK+,
+Motif/LessTif, MS Windows, Mac) from the same source code.
+
+%package devel
+Summary: The GTK+ 1.2 port of the wxWindows library
+Group: X11/Libraries
+Requires: wxGTK
+
+%description devel
+Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package gl
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Group: X11/Libraries
+Requires: wxGTK
+
+%description gl
+OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
%prep
-%setup -n wxGTK
-./configure --prefix=/usr --with-threads
+%setup -n wxGTK-%{ver}
+./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
%build
-make src
+if [ "$SMP" != "" ]; then
+ export MAKE="make -j$SMP"
+else
+ export MAKE="make"
+fi
+$MAKE
%install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
%post
/sbin/ldconfig
/sbin/ldconfig
%files
+%defattr(-, root, root)
%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-/usr/include/wx
-/usr/lib/wx
-/usr/lib/libwx_gtk_1_0.a
-/usr/lib/libwx_gtk_1_0.so
-/usr/lib/libwx_gtk_1_0.so.1
-/usr/lib/libwx_gtk_1_0.so.1.99
-/usr/bin/wx-config
+%dir %{pref}/share/wx
+%{pref}/share/wx/*
+%attr(755, root, root) %{pref}/lib/libwx_gtk.*
+%attr(755, root, root) %{pref}/lib/libwx_gtk-2.3.*
+
+%files devel
+%defattr(-,root,root)
+%dir %{pref}/include/wx
+%{pref}/include/wx/*
+%dir %{pref}/lib/wx
+%{pref}/lib/wx/*
+%attr(755, root, root) %{pref}/bin/wxgtk-config
+%attr(755, root, root) %{pref}/bin/wx-config
+
+%files gl
+%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
+
+