]> git.saurik.com Git - wxWidgets.git/blobdiff - debian/rules
lastChar was defined as a char when it should have been an int
[wxWidgets.git] / debian / rules
index 314c07d7edda91ff86870a604e9fb99eccdfacc1..efdbf594691c6a4e24ce8c8173eca17c94a71a7c 100755 (executable)
@@ -286,19 +286,16 @@ build-examples-stamp: build-gtk-shared-stamp
        rm -f $(objdir_examples)/samples/Makefile
        cp -a $(objdir_gtk_shared)/samples/Makefile $(objdir_examples)/samples
 
-       cp -a demos $(objdir_examples)
+       cd $(objdir_examples)/samples                                   \
+               && find -name 'Makefile.in' -exec rm -f '{}' ';'        \
+               && for d in $$(find -type d); do                        \
+                       if [ -f $$d/makefile.unx ]; then                \
+                               mv $$d/makefile.unx $$d/Makefile;       \
+                       fi;                                             \
+               done                                                    \
+
        cp -a wxPython/demo $(objdir_examples)/wxPython
-       @for d in $(objdir_examples)/demos $(objdir_examples)/samples; do \
-               (cd $$d \
-                       && mv Makefile.in Makefile \
-                       && rm -f configure* \
-                       && find -name 'Makefile.in' -exec rm -f '{}' ';' \
-                       && for f in $$(find -type d); do \
-                               if [ -f $$f/makefile.unx ]; then \
-                                       mv $$f/makefile.unx $$f/Makefile; \
-                               fi; \
-                       done) \
-       done;
+
        touch $@
 
 build-i18n-stamp: build-gtk-shared-stamp
@@ -379,6 +376,9 @@ clean: debian/control
                && rm -rf contrib/xrc/contrib \
                && rm -rf *.pyc
 
+       cd wxPython/include/wx                                          \
+               && for f in $(contrib_libs); do $(RM) $$f; done
+
 # We do the equivalent of this above by removing build, unfortunately
 # its not enough by itself to get the tree properly clean again.
 #              && ./setup.py clean