%define pref /usr
-%define ver 2.3.1
-%define rel 1
+%define ver 2.3.2
+%define ver2 2.3
+%define rel 0
Summary: The GTK+ 1.2 port of the wxWindows library
Name: wxGTK
# all packages providing an implementation of wxWindows library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
-# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
Provides: wxwin
# in addition, we should provide libwx_gtk as automatic generator only notices
# libwx_gtk-%{ver}-%{rel}
Provides: libwx_gtk.so
-Provides: libwx_gtk-2.3.so
+Provides: libwx_gtk-%{ver2}.so
%description
wxWindows is a free C++ library for cross-platform GUI development.
%prep
%setup -n wxGTK-%{ver}
-./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
+./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
%build
if [ "$SMP" != "" ]; then
export MAKE="make"
fi
$MAKE
+(cd locale ; make allmo)
%install
rm -rf $RPM_BUILD_ROOT
%postun
/sbin/ldconfig
+%post gl
+/sbin/ldconfig
+
+%postun gl
+/sbin/ldconfig
+
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+ ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+ SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
+ SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+ if test "x$SUM1" = "x$SUM2" ; then
+ rm -f %{_bindir}/wx-config
+ fi
+fi
+
+
%files
-%defattr(-, root, root)
-%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-%dir %{pref}/share/wx
-%{pref}/share/wx/*
-%attr(755, root, root) %{pref}/lib/libwx_gtk.*
-%attr(755, root, root) %{pref}/lib/libwx_gtk-2.3.*
+%defattr(-,root,root)
+%doc COPYING.LIB *.txt
+%dir %{_datadir}/wx
+%{_datadir}/wx/*
+%{_datadir}/locale/*/*/*.mo
+%{_libdir}/libwx_gtk-%{ver2}*.so.*
%files devel
%defattr(-,root,root)
-%dir %{pref}/include/wx
-%{pref}/include/wx/*
-%dir %{pref}/lib/wx
-%{pref}/lib/wx/*
-%attr(755, root, root) %{pref}/bin/wxgtk-config
-%attr(755, root, root) %{pref}/bin/wx-config
+%{_libdir}/libwx_gtk-%{ver2}*.so
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxgtk-%{ver2}-config
%files gl
-%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
-
+%defattr(-,root,root)
+%{_libdir}/libwx_gtk_gl*