]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMotif.spec
remove wxFileConfig tests: FileConfigTestCase already tests features tested by consol...
[wxWidgets.git] / wxMotif.spec
index 95911bff91d0d28519a84a7ea438a31a4cba33ad..708fe15c05dd9e745ded941f7ecbe4c5024cf880 100644 (file)
@@ -1,5 +1,5 @@
 %define pref /usr
-%define ver  2.9.0
+%define ver  2.9.1
 %define ver2 2.9
 %define rel  1
 
@@ -88,7 +88,7 @@ fi
 
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
+../configure --prefix=%{pref} --with-motif --with-opengl
 $MAKE
 
 cd contrib/src
@@ -97,7 +97,7 @@ cd ../../..
 
 mkdir obj-static
 cd obj-static
-../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl 
+../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
 $MAKE
 cd ..
 
@@ -111,23 +111,30 @@ rm -rf $RPM_BUILD_ROOT
 # --- wxBase headers list begins here ---
 cat <<EOF >wxbase-headers.files
 wx/afterstd.h
+wx/any.h
+wx/anystr.h
 wx/app.h
 wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
 wx/chartype.h
+wx/checkeddelete.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
 wx/convauto.h
 wx/containr.h
 wx/cpp.h
+wx/crt.h
 wx/datetime.h
 wx/datstrm.h
 wx/dde.h
@@ -135,11 +142,13 @@ wx/debug.h
 wx/defs.h
 wx/dir.h
 wx/dlimpexp.h
+wx/dlist.h
 wx/dynarray.h
 wx/dynlib.h
 wx/dynload.h
 wx/encconv.h
 wx/event.h
+wx/evtloop.h
 wx/except.h
 wx/features.h
 wx/flags.h
@@ -166,8 +175,8 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
+wx/kbdstate.h
+wx/language.h
 wx/link.h
 wx/list.h
 wx/listimpl.cpp
@@ -179,6 +188,7 @@ wx/memory.h
 wx/memtext.h
 wx/mimetype.h
 wx/module.h
+wx/mousestate.h
 wx/msgout.h
 wx/mstream.h
 wx/object.h
@@ -187,14 +197,19 @@ wx/platinfo.h
 wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
 wx/recguard.h
 wx/regex.h
+wx/scopedarray.h
+wx/scopedptr.h
 wx/scopeguard.h
+wx/sharedptr.h
 wx/snglinst.h
 wx/sstream.h
 wx/stack.h
 wx/stackwalk.h
 wx/stdpaths.h
+wx/stdstream.h
 wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
@@ -210,53 +225,67 @@ wx/textfile.h
 wx/thread.h
 wx/thrimpl.cpp
 wx/timer.h
+wx/tls.h
 wx/tokenzr.h
+wx/tracker.h
+wx/translation.h
 wx/txtstrm.h
+wx/typeinfo.h
 wx/types.h
 wx/unichar.h
 wx/uri.h
+wx/ustring.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
 wx/wxcrt.h
+wx/wxcrtbase.h
 wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
 wx/xtistrm.h
 wx/zipstrm.h
 wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/fswatcher.h
+wx/generic/fswatcher.h
 wx/unix/app.h
 wx/unix/apptbase.h
 wx/unix/apptrait.h
-wx/unix/execute.h
+wx/unix/chkconf.h
 wx/unix/evtloop.h
-wx/unix/mimetype.h
+wx/unix/evtloopsrc.h
 wx/unix/pipe.h
-wx/unix/private.h
-wx/unix/stackwalk.h
 wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/tls.h
+wx/unix/fswatcher_kqueue.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/fswatcher_inotify.h
 wx/fs_inet.h
-wx/gsocket.h
 wx/protocol/file.h
 wx/protocol/ftp.h
 wx/protocol/http.h
+wx/protocol/log.h
 wx/protocol/protocol.h
 wx/sckaddr.h
 wx/sckipc.h
 wx/sckstrm.h
 wx/socket.h
 wx/url.h
-wx/unix/gsockunx.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
@@ -327,7 +356,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
-%{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
@@ -338,7 +366,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %defattr(-,root,root)
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
-%{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so