]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Added code to the RIGHT CLICK popup dialog to show the type:name of the widget/dialog...
[wxWidgets.git] / wxGTK.spec
index 0c91a27c3e3b7c4f2a0ac97ea305d178cc2c4bd5..40f00540ea65ceee7ae561fa9dc4f84c02e928f8 100644 (file)
@@ -1,23 +1,55 @@
-Summary: The GTK+ 1.0 port of wxWindows library
+# Note that this is NOT a relocatable package
+%define pref /usr
+%define ver 2.3.0
+%define rel 0
+
+Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
-Version: 1.99.3
-Release: 1
+Version: %{ver}
+Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK2b3.tgz
-URL: http://www.freiburg.linux.de/~wxxt/docs.html
-Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-Requires: gtk+ >= 1.0.4
+Source: wxGTK-%{ver}.tgz
+URL: http://wxwindows.org
+Packager: Robert Roebling <robert@roebling.de>
+
+# all packages providing an implementation of wxWindows library (regardless of
+# the toolkit used) should provide the (virtual) wxwin package, this makes it
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+Provides: wxwin
 
 %description
-wxWindows is a free C++ library for cross-platform GUI development. With wxWindows, you can create applications for different GUIs from the same source code. This package also contains a dialog editor.
+wxWindows is a free C++ library for cross-platform GUI development.
+With wxWindows, you can create applications for different GUIs (GTK+,
+Motif/LessTif, MS Windows, Mac) from the same source code.
+
+%package devel
+Summary: The GTK+ 1.2 port of the wxWindows library
+Group: X11/Libraries
+Requires: wxGTK
+
+%description devel
+Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package gl
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Group: X11/Libraries
+Requires: wxGTK
+
+%description gl
+OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
 %setup -n wxGTK
-./configure --prefix=/usr --with-threads
+./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
-make
+if [ "$SMP" != "" ]; then
+  export MAKE="make -j$SMP"
+else
+  export MAKE="make"
+fi
+$MAKE
 
 %install
 make install
@@ -29,11 +61,21 @@ make install
 /sbin/ldconfig
 
 %files
+%defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-/usr/include/wx
-/usr/lib/wx
-/usr/lib/libwx_gtk2.so
-/usr/lib/libwx_gtk2.so.0
-/usr/lib/libwx_gtk2.so.0.1
-/usr/bin/wx-config
+%dir %{pref}/share/wx
+%{pref}/share/wx/*
+%attr(755, -, -) %{pref}/lib/libwx_gtk.*
+%attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
+
+%files devel
+%defattr (644, root, root, 755)
+%dir %{pref}/include/wx
+%{pref}/include/wx/*
+%dir %{pref}/lib/wx
+%{pref}/lib/wx/*
+%attr(755, -, -) %{pref}/bin/wxgtk-config
+%attr(755, -, -) %{pref}/bin/wx-config
 
+%files gl
+%attr(755, -, -) %{pref}/lib/libwx_gtk_gl*