]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMotif.spec
switch to pImpl pattern for mac printing
[wxWidgets.git] / wxMotif.spec
index 30407e07785caf7bab0cd0ad3ea92b20a246bbb7..c657baa721bb60f7938f9403c71383004337a8d7 100644 (file)
@@ -3,12 +3,12 @@
 
 # Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.3.2
-%define ver2 2.3
+%define ver 2.5.0
+%define ver2 2.5
 %define rel 1
 
 Summary: The Motif/Lesstif port of the wxWindows library
-Name: wxMOTIF
+Name: wxMotif
 Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
@@ -31,22 +31,29 @@ Motif/LessTif, MS Windows, Mac) from the same source code.
 %package devel
 Summary: The Motif/Lesstif port of the wxWindows library
 Group: X11/Libraries
-Requires: wxMotif
+Requires: wxMotif = %{ver}
 
 %description devel
 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
 
 %package gl
-Summary: The Motif/Lesstif port of the wxWindows library, OpenGl add-on.
+Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
 Group: X11/Libraries
-Requires: wxMotif
+Requires: wxMotif = %{ver}
 
 %description gl
-OpenGl add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
+OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
+
+%package static
+Summary: wxMotif static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
+
 
 %prep
-%setup
-./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
+%setup -n wxMOTIF-%{ver}
 
 %build
 if [ "$SMP" != "" ]; then
@@ -54,12 +61,25 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
 $MAKE
-(cd locale ; make allmo)
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl --with-motif
+$MAKE
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -93,12 +113,11 @@ if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
 fi
 
 
-%files
+%files -f wxstd.lang
 %defattr (-,root,root)
 %doc COPYING.LIB *.txt
 %dir %{_datadir}/wx
 %{_datadir}/wx/*
-%{_datadir}/locale/*/*/*.mo
 %{_libdir}/libwx_motif-%{ver2}*.so.*
 
 %files devel
@@ -109,7 +128,12 @@ fi
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
 %{_bindir}/wxmotif-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
 %files gl
 %defattr(-,root,root)
 %{_libdir}/libwx_motif_gl*
+
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a