]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
have CGImage Support in all OSX builds
[wxWidgets.git] / wxGTK.spec
index ae9e8aa6365fdd9a5c92a7f11582b59c55fc2689..a5b01d80a20741095a833ce00a6a1e097487de96 100644 (file)
@@ -1,5 +1,5 @@
 %define pref /usr
-%define ver 2.5.1
+%define ver 2.5.4
 %define ver2 2.5
 %define rel 1
 
@@ -8,7 +8,7 @@
 %{?_with_unicode: %{expand: %%define unicode 1}}
 %{?_without_unicode: %{expand: %%define unicode 0}}
 
-%define gtk2 0
+%define gtk2 1
 %{?_with_gtk2: %{expand: %%define gtk2 1}}
 %{?_without_gtk2: %{expand: %%define gtk2 0}}
 
 %endif
 
 %if %{unicode}
-%define wxconfigname wx%{portname}u-%{ver2}-config
+%define wxconfigname %{portname}-unicode-release-%{ver2}
+%define wxconfiglinkname wx%{portname}u-%{ver2}-config
 %else
-%define wxconfigname wx%{portname}-%{ver2}-config
+%define wxconfigname %{portname}-ansi-release-%{ver2}
+%define wxconfiglinkname wx%{portname}-%{ver2}-config
 %endif
 
 Name:    %{name}
@@ -125,8 +127,8 @@ cd obj-shared
 %else
              --with-odbc \
 %endif
-%if %{gtk2}
-             --enable-gtk2 \
+%if %{gtk2}
+             --disable-gtk2 \
 %endif
              --with-opengl
 $MAKE
@@ -142,8 +144,8 @@ cd obj-static
 %else
              --with-odbc \
 %endif
-%if %{gtk2}
-             --enable-gtk2 \
+%if %{gtk2}
+             --disable-gtk2 \
 %endif
              --with-opengl
 $MAKE
@@ -161,6 +163,7 @@ cat <<EOF >wxbase-headers-list
 wx/afterstd.h
 wx/app.h
 wx/apptrait.h
+wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
 wx/beforestd.h
@@ -179,11 +182,13 @@ wx/dde.h
 wx/debug.h
 wx/defs.h
 wx/dir.h
+wx/dlimpexp.h
 wx/dynarray.h
 wx/dynlib.h
 wx/dynload.h
 wx/encconv.h
 wx/event.h
+wx/except.h
 wx/features.h
 wx/ffile.h
 wx/file.h
@@ -227,6 +232,11 @@ wx/ptr_scpd.h
 wx/regex.h
 wx/scopeguard.h
 wx/snglinst.h
+wx/sstream.h
+wx/stack.h
+wx/stackwalk.h
+wx/stdpaths.h
+wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
@@ -240,6 +250,7 @@ wx/timer.h
 wx/tokenzr.h
 wx/txtstrm.h
 wx/types.h
+wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
@@ -258,8 +269,10 @@ wx/msw/apptbase.h
 wx/msw/chkconf.h
 wx/msw/crashrpt.h
 wx/msw/dde.h
+wx/msw/debughlp.h
 wx/msw/gccpriv.h
 wx/msw/mimetype.h
+wx/msw/stackwalk.h
 wx/msw/winundef.h
 wx/msw/wrapcctl.h
 wx/msw/wrapwin.h
@@ -283,15 +296,21 @@ wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
-  rm -f $RPM_BUILD_ROOT%{_includedir}/$f
+  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
 done
 
 # list of all core headers:
-find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
+find $RPM_BUILD_ROOT/usr/include/wx-* -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
 
 # contrib stuff:
 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
-(cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+# remove wxBase files so that RPM doesn't complain about unpackaged files:
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
+rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
+rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -309,30 +328,29 @@ rm -rf $RPM_BUILD_ROOT
 /sbin/ldconfig
 
 %post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
-    ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
+# link wx-config when you install RPM.
+ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx-config
+# link wx-config with explicit name.
+ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
+                                                                                   
 %preun devel
-# Remove wx-config if it points to this package
 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
+  SUM1=`md5sum %{_libdir}/wx/config/%{wxconfigname} | cut -c 0-32`
   SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
   if test "x$SUM1" = "x$SUM2" ; then
     rm -f %{_bindir}/wx-config
   fi
 fi
-
+                                                                                   
+rm -f %{_bindir}/%{wxconfiglinkname}
 
 %files
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
-%dir %{_datadir}/wx
-%{_datadir}/wx/*
 %{_libdir}/libwx_%{portname}*_core*.so.*
 %{_libdir}/libwx_%{portname}*_html*.so.*
 %{_libdir}/libwx_%{portname}*_adv*.so.*
+%{_libdir}/libwx_%{portname}*_media*.so.*
 %if !%{unicode}
 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
 %endif
@@ -342,13 +360,13 @@ fi
 %{_libdir}/libwx_%{portname}*_core*.so
 %{_libdir}/libwx_%{portname}*_html*.so
 %{_libdir}/libwx_%{portname}*_adv*.so
+%{_libdir}/libwx_%{portname}*_media*.so
 %if !%{unicode}
 %{_libdir}/libwx_%{portname}*_dbgrid*.so
 %endif
 %{_libdir}/libwx_%{portname}*_gl*.so
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
-%{_bindir}/%{wxconfigname}
 
 %files gl
 %defattr(-,root,root)
@@ -373,43 +391,43 @@ fi
 
 %files contrib-devel
 %defattr(-,root,root)
-%{_bindir}/wxrc
-%dir %{_includedir}/wx/animate
-%{_includedir}/wx/animate/*
+%{_bindir}/wxrc*
+%dir %{_includedir}/wx-*/wx/animate
+%{_includedir}/wx-*/wx/animate/*
 %{_libdir}/libwx_%{portname}*_animate*.so
 
-%dir %{_includedir}/wx/deprecated
-%{_includedir}/wx/deprecated/*
+%dir %{_includedir}/wx-*/wx/deprecated
+%{_includedir}/wx-*/wx/deprecated/*
 %{_libdir}/libwx_%{portname}*_deprecated*.so
 
-%dir %{_includedir}/wx/fl
-%{_includedir}/wx/fl/*
+%dir %{_includedir}/wx-*/wx/fl
+%{_includedir}/wx-*/wx/fl/*
 %{_libdir}/libwx_%{portname}*_fl*.so
 
-%dir %{_includedir}/wx/gizmos
-%{_includedir}/wx/gizmos/*
+%dir %{_includedir}/wx-*/wx/gizmos
+%{_includedir}/wx-*/wx/gizmos/*
 %{_libdir}/libwx_%{portname}*_gizmos*.so
 
-%dir %{_includedir}/wx/mmedia
-%{_includedir}/wx/mmedia/*
+%dir %{_includedir}/wx-*/wx/mmedia
+%{_includedir}/wx-*/wx/mmedia/*
 %{_libdir}/libwx_%{portname}*_mmedia*.so
 
-%dir %{_includedir}/wx/ogl
-%{_includedir}/wx/ogl/*
+%dir %{_includedir}/wx-*/wx/ogl
+%{_includedir}/wx-*/wx/ogl/*
 %{_libdir}/libwx_%{portname}*_ogl*.so
 
-%dir %{_includedir}/wx/plot
-%{_includedir}/wx/plot/*
+%dir %{_includedir}/wx-*/wx/plot
+%{_includedir}/wx-*/wx/plot/*
 %{_libdir}/libwx_%{portname}*_plot*.so
 
-%dir %{_includedir}/wx/stc
-%{_includedir}/wx/stc/*
+%dir %{_includedir}/wx-*/wx/stc
+%{_includedir}/wx-*/wx/stc/*
 %{_libdir}/libwx_%{portname}*_stc*.so
 
-%dir %{_includedir}/wx/svg
-%{_includedir}/wx/svg/*
+%dir %{_includedir}/wx-*/wx/svg
+%{_includedir}/wx-*/wx/svg/*
 %{_libdir}/libwx_%{portname}*_svg*.so
 
-%dir %{_includedir}/wx/xrc
-%{_includedir}/wx/xrc/*
+%dir %{_includedir}/wx-*/wx/xrc
+%{_includedir}/wx-*/wx/xrc/*
 %{_libdir}/libwx_%{portname}*_xrc*.so