%define pref /usr
-%define ver 2.5.1
+%define ver 2.5.3
%define ver2 2.5
%define rel 1
cd obj-shared
../configure --prefix=%{pref} --disable-gui \
%if %{unicode}
- --enable-unicode \
+ --enable-unicode
%else
- --with-odbc \
+ --with-odbc
%endif
- --disable-std_iostreams
$MAKE
cd ..
cd obj-static
../configure --prefix=%{pref} --disable-shared --disable-gui \
%if %{unicode}
- --enable-unicode \
+ --enable-unicode
%else
- --with-odbc \
+ --with-odbc
%endif
- --disable-std_iostreams
$MAKE
cd ..
%postun
/sbin/ldconfig
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
- ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
- SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
- SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
- if test "x$SUM1" = "x$SUM2" ; then
- rm -f %{_bindir}/wx-config
- fi
-fi
-
%files -f wxstd.lang
%defattr (-,root,root)
%doc COPYING.LIB *.txt
%files devel
%defattr (-,root,root)
-%dir %{_includedir}/wx
-%{_includedir}/wx/*
+%dir %{_includedir}/wx-*
+%{_includedir}/wx-*/*
%{_libdir}/libwx_base*.so
%dir %{_libdir}/wx
%{_libdir}/wx/*
%{_bindir}/wxbase*-%{ver2}-config
+%{_bindir}/wx-config
%{_datadir}/aclocal/*.m4
%files static