%define _prefix /opt/gnome
-%define ver 2.6.0
+%define ver 2.6.2
%define ver2 2.6
%define rel 1
%if %{unicode}
%define buildname gtk2u
%else
- %define buildname gtk2u
+ %define buildname gtk2
%endif
%else
%define gtkver 1.2
%define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
%define wxconfiglink wx%{portname}u-%{ver2}-config
%else
- %define name wx-%{portname}
+ %define name wx-%{portname}-ansi
%define wxconfig %{portname}-ansi-release-%{ver2}
%define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
%define wxconfiglink wx%{portname}-%{ver2}-config
With wxWidgets, you can create applications for different GUIs (GTK+,
Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
+%package -n wx-i18n
+Summary: The translations for the wxWidgets library.
+Group: X11/Libraries
+
+%description -n wx-i18n
+The translations files for the wxWidgets library.
+
%package devel
Summary: The GTK+ %{gtkver} port of the wxWidgets library
Group: X11/Libraries
operations, time/date manipulations, threads, processes, sockets, shared
library loading) as well as other utility classes (streams, archive and
compression). wxBase currently supports Win32, most Unix variants (Linux,
-FreeBSD, Solaris, HP-UX) and MacOS X 10.3.
+FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
%package -n %{wxbasename}-devel
Summary: wxBase library, header files.
cd obj-shared-no-gui
../configure --prefix=%{_prefix} \
--disable-gui \
- --disable-optimise \
%if %{unicode}
--enable-unicode
%else
cd obj-shared
../configure --prefix=%{_prefix} \
%if ! %{gtk2}
- --with-gtk1 \
+ --with-gtk=1 \
%else
- --with-gtk2 \
+ --with-gtk=2 \
%endif
- --disable-optimise \
%if %{unicode}
--enable-unicode \
%else
--disable-unicode \
+ --with-odbc \
%endif
--with-opengl
$MAKE
../configure --prefix=%{_prefix} \
--disable-gui \
--disable-shared \
- --disable-optimise \
%if %{unicode}
--enable-unicode
%else
cd obj-static
../configure --prefix=%{_prefix} \
%if ! %{gtk2}
- --with-gtk1 \
+ --with-gtk=1 \
%else
- --with-gtk2 \
+ --with-gtk=2 \
%endif
--disable-shared \
- --disable-optimise \
%if %{unicode}
--enable-unicode \
%else
--disable-unicode \
+ --with-odbc \
%endif
--with-opengl
$MAKE
rm -rf $RPM_BUILD_ROOT
(cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
(cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared-no-gui; DESTDIR=$RPM_BUILD_ROOT install)
+(cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
(cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
# --- wxBase headers list begins here ---
wx/config.h
wx/containr.h
wx/datetime.h
-wx/datetime.inl
wx/datstrm.h
wx/dde.h
wx/debug.h
/sbin/ldconfig
%preun devel
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
- SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
- SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
- if test "x$SUM1" = "x$SUM2" ; then
- rm -f %{_bindir}/wx-config
- fi
-fi
+%if %{unicode}
+ rm -f %{_bindir}/wx-config
+%endif
rm -f %{_bindir}/%{wxconfiglink}
%post -n %{wxbasename}
%{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
+%files -n wx-i18n
+%defattr(-,root,root)
+%{_datadir}/locale/*/*/*
%files devel -f core-headers.files
%defattr(-,root,root)
%files -n %{wxbasename}
%defattr(-,root,root)
%{_libdir}/libwx_base*-%{ver2}.so.*
-#%{_datadir}/locale/*/*/*
%files -n %{wxbasename}-devel -f wxbase-headers.paths
%defattr (-,root,root)