]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMotif.spec
Make sure paragraph style is reset before applying a new style
[wxWidgets.git] / wxMotif.spec
index f6d8e49bbedd48a7ca3e0b6ee0e975eee827907d..d5fb0fef8715635b43844618fc4fd5f56dd6f4ef 100644 (file)
@@ -1,6 +1,6 @@
 %define pref /usr
-%define ver  2.7.0
-%define ver2 2.7
+%define ver  2.9.0
+%define ver2 2.9
 %define rel  1
 
 %define portname   motif
@@ -88,7 +88,7 @@ fi
 
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
+../configure --prefix=%{pref} --with-motif --with-opengl
 $MAKE
 
 cd contrib/src
@@ -97,7 +97,7 @@ cd ../../..
 
 mkdir obj-static
 cd obj-static
-../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl 
+../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
 $MAKE
 cd ..
 
@@ -116,17 +116,22 @@ wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
+wx/chartype.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
 wx/convauto.h
 wx/containr.h
 wx/cpp.h
+wx/crt.h
 wx/datetime.h
 wx/datstrm.h
 wx/dde.h
@@ -141,6 +146,7 @@ wx/encconv.h
 wx/event.h
 wx/except.h
 wx/features.h
+wx/flags.h
 wx/ffile.h
 wx/file.h
 wx/fileconf.h
@@ -164,8 +170,6 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
 wx/link.h
 wx/list.h
 wx/listimpl.cpp
@@ -185,6 +189,7 @@ wx/platinfo.h
 wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
 wx/recguard.h
 wx/regex.h
 wx/scopeguard.h
@@ -198,6 +203,9 @@ wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
 wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
 wx/sysopt.h
 wx/tarstrm.h
 wx/textbuf.h
@@ -206,30 +214,47 @@ wx/thread.h
 wx/thrimpl.cpp
 wx/timer.h
 wx/tokenzr.h
+wx/tracker.h
 wx/txtstrm.h
 wx/types.h
+wx/unichar.h
 wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
 wx/xtistrm.h
 wx/zipstrm.h
 wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/private/fdiodispatcher.h
+wx/private/selectdispatcher.h
+wx/unix/app.h
 wx/unix/apptbase.h
 wx/unix/apptrait.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
+wx/unix/pipe.h
+wx/unix/stdpaths.h
+wx/unix/stackwalk.h
 wx/unix/execute.h
 wx/unix/mimetype.h
-wx/unix/pipe.h
 wx/unix/private.h
-wx/unix/stackwalk.h
-wx/unix/stdpaths.h
+wx/private/gsocketiohandler.h
 wx/fs_inet.h
 wx/gsocket.h
 wx/protocol/file.h
@@ -244,9 +269,6 @@ wx/url.h
 wx/unix/gsockunx.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
@@ -317,7 +339,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
-%{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
@@ -328,7 +349,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %defattr(-,root,root)
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
-%{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so