# Note that this is NOT a relocatable package
%define pref /usr
-%define ver 2.3.1
+%define ver 2.3.3
%define ver2 2.3
%define rel 1
Release: %{rel}
Copyright: wxWindows Licence
Group: X11/Libraries
-Source: wxMotif-%{ver}.tgz
+Source: wxMOTIF-%{ver}.tar.bz2
URL: http://www.wxwindows.org
Packager: Robert Fendt <rfendt@myokay.net>
BuildRoot: /tmp/wxmotif_root
%package devel
Summary: The Motif/Lesstif port of the wxWindows library
Group: X11/Libraries
-Requires: wxMotif
+Requires: wxMotif = %{ver}
%description devel
Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
%package gl
-Summary: The Motif/Lesstif port of the wxWindows library, OpenGl add-on.
+Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
Group: X11/Libraries
-Requires: wxMotif
+Requires: wxMotif = %{ver}
%description gl
-OpenGl add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
+OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
+
+%package static
+Summary: wxMotif static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
+
%prep
-%setup -n wxMotif
-./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
+%setup -n wxMOTIF-%{ver}
%build
if [ "$SMP" != "" ]; then
else
export MAKE="make"
fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl --with-motif
+$MAKE
+cd ..
%install
rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
%clean
rm -rf $RPM_BUILD_ROOT
%postun
/sbin/ldconfig
-%files
-%defattr (644, root, root, 755)
-%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-%dir %{pref}/share/wx
-%{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_motif-%{ver2}.*
+%post gl
+/sbin/ldconfig
+
+%postun gl
+/sbin/ldconfig
+
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+ ln -sf wxmotif-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+ SUM1=`md5sum %{_bindir}/wxmotif-%{ver2}-config | cut -c 0-32`
+ SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+ if test "x$SUM1" = "x$SUM2" ; then
+ rm -f %{_bindir}/wx-config
+ fi
+fi
+
+
+%files -f wxstd.lang
+%defattr (-,root,root)
+%doc COPYING.LIB *.txt
+%dir %{_datadir}/wx
+%{_datadir}/wx/*
+%{_libdir}/libwx_motif-%{ver2}*.so.*
%files devel
-%defattr (644, root, root, 755)
-%dir %{pref}/include/wx
-%{pref}/include/wx/*
-%dir %{pref}/lib/wx
-%{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wxmotif-%{ver2}-config
-%attr(755, -, -) %{pref}/bin/wx-config
+%defattr (-,root,root)
+%{_libdir}/libwx_motif-%{ver2}*.so
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxmotif-%{ver2}-config
+%{_datadir}/aclocal/*.m4
%files gl
-%attr(755, -, -) %{pref}/lib/libwx_motif_gl*
+%defattr(-,root,root)
+%{_libdir}/libwx_motif_gl*
+
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a