]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Updated/Added build instructions for OS/2.
[wxWidgets.git] / wxGTK.spec
index 85ede5103653e586d3a0a99598386b6c40665d2e..d126784a6c05196591fc1508de4b4e4cc7517543 100644 (file)
@@ -1,7 +1,7 @@
 # Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.1.0
-%define rel 6
+%define ver 2.1.14
+%define rel 0
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -9,10 +9,9 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.0-b6.tgz
+Source: wxGTK-%{ver}.tar.gz
 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-Requires: gtk+ >= 1.2.1
 BuildRoot: /tmp/wxgtk_root
 
 # all packages providing an implementation of wxWindows library (regardless of
@@ -25,12 +24,25 @@ wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
 Motif/LessTif, MS Windows, Mac) from the same source code.
 
+%package devel
+Summary: The GTK+ 1.2 port of the wxWindows library
+Group: X11/Libraries
+Requires: wxGTK
+
+%description devel
+Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
 %prep
 %setup -n wxGTK
-./configure --prefix=%{pref} --with-threads
+./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
 
 %build
-make
+if [ "$SMP" != "" ]; then
+  export MAKE="make -j$SMP"
+else
+  export MAKE="make"
+fi
+$MAKE
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -48,12 +60,15 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
+%dir %{pref}/share/wx
+%{pref}/share/wx/*
+%attr(755, -, -) %{pref}/lib/libwx_gtk*
+
+%files devel
+%defattr (644, root, root, 755)
 %dir %{pref}/include/wx
 %{pref}/include/wx/*
 %dir %{pref}/lib/wx
 %{pref}/lib/wx/*
-%dir %{pref}/share/wx
-%{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk*
 %attr(755, -, -) %{pref}/bin/wx-config