]> git.saurik.com Git - wxWidgets.git/blobdiff - wxX11.spec
Fix crash when using a proxy (m_protocol already gets cleaned up via CleanData())
[wxWidgets.git] / wxX11.spec
index c54305444c05e8e39a75996dd9f95f5f099a8dcf..b586926a7cf1cecb4672fd0cfb82c13999464b08 100644 (file)
@@ -1,5 +1,5 @@
 %define pref /usr
-%define ver 2.5.1
+%define ver 2.5.4
 %define ver2 2.5
 %define rel 1
 
@@ -142,6 +142,7 @@ cat <<EOF >wxbase-headers-list
 wx/afterstd.h
 wx/app.h
 wx/apptrait.h
+wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
 wx/beforestd.h
@@ -160,6 +161,7 @@ wx/dde.h
 wx/debug.h
 wx/defs.h
 wx/dir.h
+wx/dlimpexp.h
 wx/dynarray.h
 wx/dynlib.h
 wx/dynload.h
@@ -177,7 +179,6 @@ wx/fontenc.h
 wx/fontmap.h
 wx/fs_mem.h
 wx/fs_zip.h
-wx/gzstream.h
 wx/hash.h
 wx/hashmap.h
 wx/hashset.h
@@ -210,7 +211,11 @@ wx/ptr_scpd.h
 wx/regex.h
 wx/scopeguard.h
 wx/snglinst.h
+wx/sstream.h
 wx/stack.h
+wx/stackwalk.h
+wx/stdpaths.h
+wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
@@ -224,6 +229,7 @@ wx/timer.h
 wx/tokenzr.h
 wx/txtstrm.h
 wx/types.h
+wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
@@ -242,8 +248,10 @@ wx/msw/apptbase.h
 wx/msw/chkconf.h
 wx/msw/crashrpt.h
 wx/msw/dde.h
+wx/msw/debughlp.h
 wx/msw/gccpriv.h
 wx/msw/mimetype.h
+wx/msw/stackwalk.h
 wx/msw/winundef.h
 wx/msw/wrapcctl.h
 wx/msw/wrapwin.h
@@ -267,7 +275,7 @@ wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
-  rm -f $RPM_BUILD_ROOT%{_includedir}/$f
+  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
 done
 
 # list of all core headers:
@@ -275,7 +283,7 @@ find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >cor
 
 # contrib stuff:
 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
-(cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
 # remove wxBase files so that RPM doesn't complain about unpackaged files:
 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
@@ -297,28 +305,10 @@ rm -rf $RPM_BUILD_ROOT
 %postun gl
 /sbin/ldconfig
 
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
-    ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
-  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
-  if test "x$SUM1" = "x$SUM2" ; then
-    rm -f %{_bindir}/wx-config
-  fi
-fi
-
 
 %files
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
-%dir %{_datadir}/wx
-%{_datadir}/wx/*
 %{_libdir}/libwx_%{portname}*_core*.so.*
 %{_libdir}/libwx_%{portname}*_html*.so.*
 %{_libdir}/libwx_%{portname}*_adv*.so.*
@@ -363,42 +353,42 @@ fi
 %files contrib-devel
 %defattr(-,root,root)
 %{_bindir}/wxrc
-%dir %{_includedir}/wx/animate
-%{_includedir}/wx/animate/*
+%dir %{_includedir}/wx-*/wx/animate
+%{_includedir}/wx-*/wx/animate/*
 %{_libdir}/libwx_%{portname}*_animate*.so
 
-%dir %{_includedir}/wx/deprecated
-%{_includedir}/wx/deprecated/*
+%dir %{_includedir}/wx-*/wx/deprecated
+%{_includedir}/wx-*/wx/deprecated/*
 %{_libdir}/libwx_%{portname}*_deprecated*.so
 
-%dir %{_includedir}/wx/fl
-%{_includedir}/wx/fl/*
+%dir %{_includedir}/wx-*/wx/fl
+%{_includedir}/wx-*/wx/fl/*
 %{_libdir}/libwx_%{portname}*_fl*.so
 
-%dir %{_includedir}/wx/gizmos
-%{_includedir}/wx/gizmos/*
+%dir %{_includedir}/wx-*/wx/gizmos
+%{_includedir}/wx-*/wx/gizmos/*
 %{_libdir}/libwx_%{portname}*_gizmos*.so
 
-%dir %{_includedir}/wx/mmedia
-%{_includedir}/wx/mmedia/*
+%dir %{_includedir}/wx-*/wx/mmedia
+%{_includedir}/wx-*/wx/mmedia/*
 %{_libdir}/libwx_%{portname}*_mmedia*.so
 
-%dir %{_includedir}/wx/ogl
-%{_includedir}/wx/ogl/*
+%dir %{_includedir}/wx-*/wx/ogl
+%{_includedir}/wx-*/wx/ogl/*
 %{_libdir}/libwx_%{portname}*_ogl*.so
 
-%dir %{_includedir}/wx/plot
-%{_includedir}/wx/plot/*
+%dir %{_includedir}/wx-*/wx/plot
+%{_includedir}/wx-*/wx/plot/*
 %{_libdir}/libwx_%{portname}*_plot*.so
 
-%dir %{_includedir}/wx/stc
-%{_includedir}/wx/stc/*
+%dir %{_includedir}/wx-*/wx/stc
+%{_includedir}/wx-*/wx/stc/*
 %{_libdir}/libwx_%{portname}*_stc*.so
 
-%dir %{_includedir}/wx/svg
-%{_includedir}/wx/svg/*
+%dir %{_includedir}/wx-*/wx/svg
+%{_includedir}/wx-*/wx/svg/*
 %{_libdir}/libwx_%{portname}*_svg*.so
 
-%dir %{_includedir}/wx/xrc
-%{_includedir}/wx/xrc/*
+%dir %{_includedir}/wx-*/wx/xrc
+%{_includedir}/wx-*/wx/xrc/*
 %{_libdir}/libwx_%{portname}*_xrc*.so