]> git.saurik.com Git - wxWidgets.git/blobdiff - wxBase.spec
Use wxIconLocation instead of wxIcon (as in the other ports).
[wxWidgets.git] / wxBase.spec
index 2c2806728ebe959f26d89ab981dbfb2d4f401bf1..45cc7e57739699c8272a093ce9e91e200d37513d 100644 (file)
@@ -3,17 +3,35 @@
 %define ver2 2.5
 %define rel 1
 
+# Configurable settings (use --with(out) unicode on rpmbuild command line):
+%define unicode 0
+%{?_with_unicode: %{expand: %%define unicode 1}}
+%{?_without_unicode: %{expand: %%define unicode 0}}
+
+%if %{unicode}
+%define wxconfigname wxbaseu-%{ver2}-config
+%else
+%define wxconfigname wxbase-%{ver2}-config
+%endif
+
+%if %{unicode}
+%define name wx-base-unicode
+%else 
+%define name wx-base
+%endif
+
 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
-Name: wxBase
+Name:   %{name}
 Version: %{ver}
 Release: %{rel}
-Copyright: wxWindows Licence
+License: wxWindows Licence
 Group: Development/Libraries
 Source: wxBase-%{ver}.tar.bz2
 URL: http://www.wxwindows.org
 Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{pref}
 BuildRoot: /var/tmp/%{name}-root
+Provides: wxBase
 
 %description
 wxBase is a collection of C++ classes providing basic data structures (strings,
@@ -27,7 +45,8 @@ the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
 %package devel
 Summary: wxBase headers needed for developping with wxBase
 Group: Development/Libraries
-Requires: wxBase = %{ver}
+Requires: %{name} = %{ver}
+Provides: wxBase-devel
 
 %description devel
 Header files for wxBase. You need them to develop programs using wxBase.
@@ -40,7 +59,7 @@ Group: Development/Libraries
 Static libraries for wxBase. You need them if you want to link statically against wxBase.
 
 %prep
-%setup -n wxBase-%{ver}
+%setup -q -n wxBase-%{ver}
 
 %build
 if [ "$SMP" != "" ]; then
@@ -51,13 +70,25 @@ fi
 
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{pref} --disable-gui --disable-std_iostreams
+../configure --prefix=%{pref} --disable-gui \
+%if %{unicode}
+             --enable-unicode \
+%else
+             --with-odbc \
+%endif
+             --disable-std_iostreams
 $MAKE
 cd ..
 
 mkdir obj-static
 cd obj-static
-../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
+../configure --prefix=%{pref} --disable-shared --disable-gui \
+%if %{unicode}
+             --enable-unicode \
+%else
+             --with-odbc \
+%endif
+             --disable-std_iostreams
 $MAKE
 cd ..
 
@@ -105,7 +136,7 @@ fi
 %{_libdir}/libwx_base*.so
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
-%{_bindir}/wxbase-%{ver2}-config
+%{_bindir}/wxbase*-%{ver2}-config
 %{_datadir}/aclocal/*.m4
 
 %files static