]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Made XPMs transparent
[wxWidgets.git] / wxGTK.spec
index f8fc676fca9e674cabb27ab17a72aa035594feb6..85eccc1678300ee89e65066f53fadbdc810cd09f 100644 (file)
@@ -1,7 +1,7 @@
 %define pref /usr
-%define ver 2.3.2
-%define ver2 2.3
-%define rel 0
+%define ver 2.5.0
+%define ver2 2.5
+%define rel 1
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -33,22 +33,28 @@ Motif/LessTif, MS Windows, Mac) from the same source code.
 %package devel
 Summary: The GTK+ 1.2 port of the wxWindows library
 Group: X11/Libraries
-Requires: wxGTK
+Requires: wxGTK = %{ver}
 
 %description devel
 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %package gl
-Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
 Group: X11/Libraries
-Requires: wxGTK
+Requires: wxGTK = %{ver}
 
 %description gl
-OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package static
+Summary: wxGTK static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
 
 %prep
 %setup -n wxGTK-%{ver}
-./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
 
 %build
 if [ "$SMP" != "" ]; then
@@ -56,12 +62,28 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
+$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
 $MAKE
-(cd locale ; make allmo)
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
@@ -92,12 +114,11 @@ if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
 fi
 
 
-%files
+%files -f wxstd.lang
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
 %dir %{_datadir}/wx
 %{_datadir}/wx/*
-%{_datadir}/locale/*/*/*.mo
 %{_libdir}/libwx_gtk-%{ver2}*.so.*
 
 %files devel
@@ -108,8 +129,12 @@ fi
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
 %{_bindir}/wxgtk-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
 %files gl
 %defattr(-,root,root)
 %{_libdir}/libwx_gtk_gl*
 
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a