]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMotif.spec
added support for range types to runtime depersister
[wxWidgets.git] / wxMotif.spec
index a943405f057f916d7749f9f289db8db042dcabd7..17b1ff4dfc863f20132d3334cd94c6df00a63a72 100644 (file)
@@ -3,15 +3,20 @@
 
 # Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.3.2
-%define ver2 2.3
+%define ver 2.5.0
+%define ver2 2.5
 %define rel 1
 
+%define portname    motif
+%define name        wx-%{portname}
+%define wxbasename  wx-base
+%define wxconfigname wx%{portname}-%{ver2}-config
+
 Summary: The Motif/Lesstif port of the wxWindows library
-Name: wxMotif
+Name: %{name}
 Version: %{ver}
 Release: %{rel}
-Copyright: wxWindows Licence
+License: wxWindows Licence
 Group: X11/Libraries
 Source: wxMOTIF-%{ver}.tar.bz2
 URL: http://www.wxwindows.org
@@ -23,6 +28,11 @@ BuildRoot: /tmp/wxmotif_root
 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
 Provides: wxwin
 
+Provides: wxMotif
+
+Requires:      %{wxbasename} = %{ver}
+BuildRequires: %{wxbasename}-devel = %{ver}
+
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
@@ -31,7 +41,8 @@ Motif/LessTif, MS Windows, Mac) from the same source code.
 %package devel
 Summary: The Motif/Lesstif port of the wxWindows library
 Group: X11/Libraries
-Requires: wxMotif = %{ver}
+Requires: %{name} = %{ver}
+Requires: %{wxbasename}-devel = %{ver}
 
 %description devel
 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
@@ -39,7 +50,7 @@ Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
 %package gl
 Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
 Group: X11/Libraries
-Requires: wxMotif = %{ver}
+Requires: %{name} = %{ver}
 
 %description gl
 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
@@ -51,9 +62,8 @@ Group: Development/Libraries
 %description static
 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
 
-
 %prep
-%setup -n wxMOTIF-%{ver}
+%setup -q -n wxMOTIF-%{ver}
 
 %build
 if [ "$SMP" != "" ]; then
@@ -64,7 +74,7 @@ fi
 
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
+../configure --prefix=%{pref} --with-odbc --with-opengl --with-motif
 $MAKE
 cd ..
 
@@ -79,7 +89,17 @@ rm -rf $RPM_BUILD_ROOT
 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
-%find_lang wxstd
+# Remove headers that are part of wx-base-devel:
+(
+cd $RPM_BUILD_ROOT
+for f in  `rpm -ql %{wxbasename}-devel | sed -e 's,\(.*\),.\1,g'` ; do
+  if test -f $f ; then rm -f $f ; fi
+done
+)
+
+# list of all core headers:
+find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -99,13 +119,13 @@ rm -rf $RPM_BUILD_ROOT
 %post devel
 # Install wx-config if there isn't any
 if test ! -f %{_bindir}/wx-config ; then
-    ln -sf wxmotif-%{ver2}-config %{_bindir}/wx-config
+    ln -sf %{wxconfigname} %{_bindir}/wx-config
 fi
 
 %preun devel
 # Remove wx-config if it points to this package
 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/wxmotif-%{ver2}-config | cut -c 0-32`
+  SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
   SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
   if test "x$SUM1" = "x$SUM2" ; then
     rm -f %{_bindir}/wx-config
@@ -113,27 +133,31 @@ if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
 fi
 
 
-%files -f wxstd.lang
-%defattr (-,root,root)
+%files
+%defattr(-,root,root)
 %doc COPYING.LIB *.txt
 %dir %{_datadir}/wx
 %{_datadir}/wx/*
-%{_libdir}/libwx_motif-%{ver2}*.so.*
+%{_libdir}/libwx_%{portname}*_core*.so.*
+%{_libdir}/libwx_%{portname}*_html*.so.*
+%{_libdir}/libwx_%{portname}*_adv*.so.*
+%{_libdir}/libwx_%{portname}*_dbgrid*.so.*
 
-%files devel
-%defattr (-,root,root)
-%{_libdir}/libwx_motif-%{ver2}*.so
-%dir %{_includedir}/wx
-%{_includedir}/wx/*
+%files devel -f core-headers.files
+%defattr(-,root,root)
+%{_libdir}/libwx_%{portname}*_core*.so
+%{_libdir}/libwx_%{portname}*_html*.so
+%{_libdir}/libwx_%{portname}*_adv*.so
+%{_libdir}/libwx_%{portname}*_dbgrid*.so
+%{_libdir}/libwx_%{portname}*_gl*.so
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
-%{_bindir}/wxmotif-%{ver2}-config
-%{_datadir}/aclocal/*.m4
+%{_bindir}/%{wxconfigname}
 
 %files gl
 %defattr(-,root,root)
-%{_libdir}/libwx_motif_gl*
+%{_libdir}/libwx_%{portname}*_gl*.so.*
 
 %files static
 %defattr (-,root,root)
-%{_libdir}/lib*.a
+%{_libdir}/libwx_%{portname}*.a