]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Sizing/scrollbar corrections for Mac
[wxWidgets.git] / wxGTK.spec
index 837d17fadf0dfd8809da8b1af92781222459e9c2..b7b5c3f3182e06845e848928128ca78048a5e507 100644 (file)
@@ -1,6 +1,6 @@
 %define _prefix /usr
-%define ver  2.7.0
-%define ver2 2.7
+%define ver  2.9.0
+%define ver2 2.9
 %define rel  1
 
 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
@@ -61,13 +61,13 @@ Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{_prefix}
 BuildRoot: %{_tmppath}/%{name}-root
 Requires: %{wxbasename} = %{ver}
-#%if %{portname} == gtk2
-#BuildRequires: gtk+-2.0-devel
-#%else
-#BuildRequires: gtk+-devel >= 1.2.0
-#%endif
-#
-#BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
+%if %{portname} == gtk2
+BuildRequires: gtk+-2.0-devel
+%else
+BuildRequires: gtk+-devel >= 1.2.0
+%endif
+
+BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
 
 # all packages providing an implementation of wxWidgets library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
@@ -167,7 +167,6 @@ cd obj-shared
                              --enable-unicode \
 %else
                              --disable-unicode \
-                             --with-odbc \
 %endif
                              --with-opengl
 $MAKE
@@ -189,7 +188,6 @@ cd obj-static
                              --enable-unicode \
 %else
                              --disable-unicode \
-                             --with-odbc \
 %endif
                              --with-opengl
 $MAKE
@@ -213,16 +211,22 @@ wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
+wx/chartype.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
 wx/convauto.h
 wx/containr.h
+wx/cpp.h
+wx/crt.h
 wx/datetime.h
 wx/datstrm.h
 wx/dde.h
@@ -237,6 +241,7 @@ wx/encconv.h
 wx/event.h
 wx/except.h
 wx/features.h
+wx/flags.h
 wx/ffile.h
 wx/file.h
 wx/fileconf.h
@@ -245,6 +250,8 @@ wx/filename.h
 wx/filesys.h
 wx/fontenc.h
 wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
 wx/fs_mem.h
 wx/fs_zip.h
 wx/hash.h
@@ -258,8 +265,6 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
 wx/link.h
 wx/list.h
 wx/listimpl.cpp
@@ -275,9 +280,11 @@ wx/msgout.h
 wx/mstream.h
 wx/object.h
 wx/platform.h
+wx/platinfo.h
 wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
 wx/recguard.h
 wx/regex.h
 wx/scopeguard.h
@@ -291,37 +298,58 @@ wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
 wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
 wx/sysopt.h
+wx/tarstrm.h
 wx/textbuf.h
 wx/textfile.h
 wx/thread.h
 wx/thrimpl.cpp
 wx/timer.h
 wx/tokenzr.h
+wx/tracker.h
 wx/txtstrm.h
 wx/types.h
+wx/unichar.h
 wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
 wx/xtistrm.h
 wx/zipstrm.h
 wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/private/fdiodispatcher.h
+wx/private/selectdispatcher.h
+wx/unix/app.h
 wx/unix/apptbase.h
 wx/unix/apptrait.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
+wx/unix/pipe.h
+wx/unix/stdpaths.h
+wx/unix/stackwalk.h
 wx/unix/execute.h
 wx/unix/mimetype.h
-wx/unix/pipe.h
 wx/unix/private.h
-wx/unix/stackwalk.h
-wx/unix/stdpaths.h
+wx/private/gsocketiohandler.h
 wx/fs_inet.h
 wx/gsocket.h
 wx/protocol/file.h
@@ -336,9 +364,6 @@ wx/url.h
 wx/unix/gsockunx.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 cat <<EOF >wxbase-headers.paths
@@ -357,6 +382,7 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/confbase.h
 %{_includedir}/wx-%{ver2}/wx/config.h
 %{_includedir}/wx-%{ver2}/wx/containr.h
+%{_includedir}/wx-%{ver2}/wx/convauto.h
 %{_includedir}/wx-%{ver2}/wx/datetime.h
 %{_includedir}/wx-%{ver2}/wx/datstrm.h
 %{_includedir}/wx-%{ver2}/wx/dde.h
@@ -394,6 +420,7 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
 %{_includedir}/wx-%{ver2}/wx/isql.h
 %{_includedir}/wx-%{ver2}/wx/isqlext.h
+%{_includedir}/wx-%{ver2}/wx/link.h
 %{_includedir}/wx-%{ver2}/wx/list.h
 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
 %{_includedir}/wx-%{ver2}/wx/log.h
@@ -408,8 +435,10 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/mstream.h
 %{_includedir}/wx-%{ver2}/wx/object.h
 %{_includedir}/wx-%{ver2}/wx/platform.h
+%{_includedir}/wx-%{ver2}/wx/power.h
 %{_includedir}/wx-%{ver2}/wx/process.h
 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
+%{_includedir}/wx-%{ver2}/wx/recguard.h
 %{_includedir}/wx-%{ver2}/wx/regex.h
 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
 %{_includedir}/wx-%{ver2}/wx/snglinst.h
@@ -458,15 +487,13 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/url.h
 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
 %{_includedir}/wx-%{ver2}/wx/xtixml.h
-%{_includedir}/wx-%{ver2}/wx/db.h
-%{_includedir}/wx-%{ver2}/wx/dbkeyg.h
-%{_includedir}/wx-%{ver2}/wx/dbtable.h
 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
+%{_includedir}/wx-%{ver2}/wx/unix/private.h
 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
 EOF
@@ -485,8 +512,14 @@ cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
 rm -rf $RPM_BUILD_ROOT/_save_dir
 
 # contrib stuff:
-(cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
+(cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+(cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+
+# utils:
+(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -554,13 +587,12 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
-%endif
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
 
 %files -n wx-i18n
@@ -571,24 +603,22 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %defattr(-,root,root)
 # shared libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
-%endif
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
 # static libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
-%endif
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
 %dir %{_libdir}/wx
 %{_libdir}/wx/config/%{wxconfig}