]> git.saurik.com Git - wxWidgets.git/blobdiff - wxX11.spec
Fix crash when using a proxy (m_protocol already gets cleaned up via CleanData())
[wxWidgets.git] / wxX11.spec
index 22efc08f0f281093cb4006d96e58315191ad8d7a..b586926a7cf1cecb4672fd0cfb82c13999464b08 100644 (file)
@@ -1,5 +1,5 @@
 %define pref /usr
-%define ver 2.5.2
+%define ver 2.5.4
 %define ver2 2.5
 %define rel 1
 
@@ -142,6 +142,7 @@ cat <<EOF >wxbase-headers-list
 wx/afterstd.h
 wx/app.h
 wx/apptrait.h
+wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
 wx/beforestd.h
@@ -210,7 +211,11 @@ wx/ptr_scpd.h
 wx/regex.h
 wx/scopeguard.h
 wx/snglinst.h
+wx/sstream.h
 wx/stack.h
+wx/stackwalk.h
+wx/stdpaths.h
+wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
@@ -224,6 +229,7 @@ wx/timer.h
 wx/tokenzr.h
 wx/txtstrm.h
 wx/types.h
+wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
@@ -242,8 +248,10 @@ wx/msw/apptbase.h
 wx/msw/chkconf.h
 wx/msw/crashrpt.h
 wx/msw/dde.h
+wx/msw/debughlp.h
 wx/msw/gccpriv.h
 wx/msw/mimetype.h
+wx/msw/stackwalk.h
 wx/msw/winundef.h
 wx/msw/wrapcctl.h
 wx/msw/wrapwin.h
@@ -275,7 +283,7 @@ find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >cor
 
 # contrib stuff:
 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
-(cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
 # remove wxBase files so that RPM doesn't complain about unpackaged files:
 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
@@ -301,8 +309,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
-%dir %{_datadir}/wx
-%{_datadir}/wx/*
 %{_libdir}/libwx_%{portname}*_core*.so.*
 %{_libdir}/libwx_%{portname}*_html*.so.*
 %{_libdir}/libwx_%{portname}*_adv*.so.*