]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
compilation fix for wxUSE_STL==1
[wxWidgets.git] / wxGTK.spec
index 3e6201bd66df0f05b22b7007ab01beae1f89a657..0f9dbbf54b1ca14d059612d9ee5d85ded5b84816 100644 (file)
@@ -1,5 +1,5 @@
 %define pref /usr
-%define ver 2.5.0
+%define ver 2.5.4
 %define ver2 2.5
 %define rel 1
 
@@ -8,7 +8,7 @@
 %{?_with_unicode: %{expand: %%define unicode 1}}
 %{?_without_unicode: %{expand: %%define unicode 0}}
 
-%define gtk2 0
+%define gtk2 1
 %{?_with_gtk2: %{expand: %%define gtk2 1}}
 %{?_without_gtk2: %{expand: %%define gtk2 0}}
 
 %endif
 
 %if %{unicode}
-%define wxconfigname wx%{portname}u-%{ver2}-config
+%define wxconfigname %{portname}-unicode-release-%{ver2}
+%define wxconfiglinkname wx%{portname}u-%{ver2}-config
 %else
-%define wxconfigname wx%{portname}-%{ver2}-config
+%define wxconfigname %{portname}-ansi-release-%{ver2}
+%define wxconfiglinkname wx%{portname}-%{ver2}-config
 %endif
 
 Name:    %{name}
@@ -58,7 +60,6 @@ Provides: libwx_gtk.so
 Provides: libwx_gtk-%{ver2}.so
 
 Requires: %{wxbasename} = %{ver}
-BuildRequires: %{wxbasename}-devel = %{ver}
 
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
@@ -126,8 +127,8 @@ cd obj-shared
 %else
              --with-odbc \
 %endif
-%if %{gtk2}
-             --enable-gtk2 \
+%if %{gtk2}
+             --disable-gtk2 \
 %endif
              --with-opengl
 $MAKE
@@ -143,8 +144,8 @@ cd obj-static
 %else
              --with-odbc \
 %endif
-%if %{gtk2}
-             --enable-gtk2 \
+%if %{gtk2}
+             --disable-gtk2 \
 %endif
              --with-opengl
 $MAKE
@@ -156,19 +157,160 @@ rm -rf $RPM_BUILD_ROOT
 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
 # Remove headers that are part of wx-base-devel:
-(
-cd $RPM_BUILD_ROOT
-for f in  `rpm -ql %{wxbasename}-devel | sed -e 's,\(.*\),.\1,g'` ; do
-  if test -f $f ; then rm -f $f ; fi
+
+# --- wxBase headers list begins here ---
+cat <<EOF >wxbase-headers-list
+wx/afterstd.h
+wx/app.h
+wx/apptrait.h
+wx/archive.h
+wx/arrimpl.cpp
+wx/arrstr.h
+wx/beforestd.h
+wx/buffer.h
+wx/build.h
+wx/chkconf.h
+wx/clntdata.h
+wx/cmdline.h
+wx/confbase.h
+wx/config.h
+wx/containr.h
+wx/datetime.h
+wx/datetime.inl
+wx/datstrm.h
+wx/dde.h
+wx/debug.h
+wx/defs.h
+wx/dir.h
+wx/dlimpexp.h
+wx/dynarray.h
+wx/dynlib.h
+wx/dynload.h
+wx/encconv.h
+wx/event.h
+wx/except.h
+wx/features.h
+wx/ffile.h
+wx/file.h
+wx/fileconf.h
+wx/filefn.h
+wx/filename.h
+wx/filesys.h
+wx/fontenc.h
+wx/fontmap.h
+wx/fs_mem.h
+wx/fs_zip.h
+wx/hash.h
+wx/hashmap.h
+wx/hashset.h
+wx/iconloc.h
+wx/init.h
+wx/intl.h
+wx/iosfwrap.h
+wx/ioswrap.h
+wx/ipc.h
+wx/ipcbase.h
+wx/isql.h
+wx/isqlext.h
+wx/list.h
+wx/listimpl.cpp
+wx/log.h
+wx/longlong.h
+wx/math.h
+wx/memconf.h
+wx/memory.h
+wx/memtext.h
+wx/mimetype.h
+wx/module.h
+wx/msgout.h
+wx/msgout.h
+wx/mstream.h
+wx/object.h
+wx/platform.h
+wx/process.h
+wx/ptr_scpd.h
+wx/regex.h
+wx/scopeguard.h
+wx/snglinst.h
+wx/sstream.h
+wx/stack.h
+wx/stackwalk.h
+wx/stdpaths.h
+wx/stockitem.h
+wx/stopwatch.h
+wx/strconv.h
+wx/stream.h
+wx/string.h
+wx/sysopt.h
+wx/textbuf.h
+wx/textfile.h
+wx/thread.h
+wx/thrimpl.cpp
+wx/timer.h
+wx/tokenzr.h
+wx/txtstrm.h
+wx/types.h
+wx/uri.h
+wx/utils.h
+wx/variant.h
+wx/vector.h
+wx/version.h
+wx/volume.h
+wx/wfstream.h
+wx/wx.h
+wx/wxchar.h
+wx/wxprec.h
+wx/xti.h
+wx/xtistrm.h
+wx/zipstrm.h
+wx/zstream.h
+wx/msw/apptrait.h
+wx/msw/apptbase.h
+wx/msw/chkconf.h
+wx/msw/crashrpt.h
+wx/msw/dde.h
+wx/msw/debughlp.h
+wx/msw/gccpriv.h
+wx/msw/mimetype.h
+wx/msw/stackwalk.h
+wx/msw/winundef.h
+wx/msw/wrapcctl.h
+wx/msw/wrapwin.h
+wx/fs_inet.h
+wx/gsocket.h
+wx/protocol/file.h
+wx/protocol/ftp.h
+wx/protocol/http.h
+wx/protocol/protocol.h
+wx/sckaddr.h
+wx/sckipc.h
+wx/sckstrm.h
+wx/socket.h
+wx/url.h
+wx/msw/gsockmsw.h
+wx/xml/xml.h
+wx/xtixml.h
+wx/db.h
+wx/dbkeyg.h
+wx/dbtable.h
+EOF
+# --- wxBase headers list ends here ---
+for f in `cat wxbase-headers-list` ; do
+  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
 done
-)
 
 # list of all core headers:
-find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
+find $RPM_BUILD_ROOT/usr/include/wx-* -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
 
 # contrib stuff:
 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
-(cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+# remove wxBase files so that RPM doesn't complain about unpackaged files:
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
+rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
+rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -186,21 +328,21 @@ rm -rf $RPM_BUILD_ROOT
 /sbin/ldconfig
 
 %post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
-    ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
+# link wx-config when you install RPM.
+ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx-config
+# link wx-config with explicit name.
+ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
+                                                                                   
 %preun devel
-# Remove wx-config if it points to this package
 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
+  SUM1=`md5sum %{_libdir}/wx/config/%{wxconfigname} | cut -c 0-32`
   SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
   if test "x$SUM1" = "x$SUM2" ; then
     rm -f %{_bindir}/wx-config
   fi
 fi
-
+                                                                                   
+rm -f %{_bindir}/%{wxconfiglinkname}
 
 %files
 %defattr(-,root,root)
@@ -210,6 +352,7 @@ fi
 %{_libdir}/libwx_%{portname}*_core*.so.*
 %{_libdir}/libwx_%{portname}*_html*.so.*
 %{_libdir}/libwx_%{portname}*_adv*.so.*
+%{_libdir}/libwx_%{portname}*_media*.so.*
 %if !%{unicode}
 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
 %endif
@@ -219,13 +362,13 @@ fi
 %{_libdir}/libwx_%{portname}*_core*.so
 %{_libdir}/libwx_%{portname}*_html*.so
 %{_libdir}/libwx_%{portname}*_adv*.so
+%{_libdir}/libwx_%{portname}*_media*.so
 %if !%{unicode}
 %{_libdir}/libwx_%{portname}*_dbgrid*.so
 %endif
 %{_libdir}/libwx_%{portname}*_gl*.so
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
-%{_bindir}/%{wxconfigname}
 
 %files gl
 %defattr(-,root,root)
@@ -250,43 +393,43 @@ fi
 
 %files contrib-devel
 %defattr(-,root,root)
-%{_bindir}/wxrc
-%dir %{_includedir}/wx/animate
-%{_includedir}/wx/animate/*
+%{_bindir}/wxrc*
+%dir %{_includedir}/wx-*/wx/animate
+%{_includedir}/wx-*/wx/animate/*
 %{_libdir}/libwx_%{portname}*_animate*.so
 
-%dir %{_includedir}/wx/deprecated
-%{_includedir}/wx/deprecated/*
+%dir %{_includedir}/wx-*/wx/deprecated
+%{_includedir}/wx-*/wx/deprecated/*
 %{_libdir}/libwx_%{portname}*_deprecated*.so
 
-%dir %{_includedir}/wx/fl
-%{_includedir}/wx/fl/*
+%dir %{_includedir}/wx-*/wx/fl
+%{_includedir}/wx-*/wx/fl/*
 %{_libdir}/libwx_%{portname}*_fl*.so
 
-%dir %{_includedir}/wx/gizmos
-%{_includedir}/wx/gizmos/*
+%dir %{_includedir}/wx-*/wx/gizmos
+%{_includedir}/wx-*/wx/gizmos/*
 %{_libdir}/libwx_%{portname}*_gizmos*.so
 
-%dir %{_includedir}/wx/mmedia
-%{_includedir}/wx/mmedia/*
+%dir %{_includedir}/wx-*/wx/mmedia
+%{_includedir}/wx-*/wx/mmedia/*
 %{_libdir}/libwx_%{portname}*_mmedia*.so
 
-%dir %{_includedir}/wx/ogl
-%{_includedir}/wx/ogl/*
+%dir %{_includedir}/wx-*/wx/ogl
+%{_includedir}/wx-*/wx/ogl/*
 %{_libdir}/libwx_%{portname}*_ogl*.so
 
-%dir %{_includedir}/wx/plot
-%{_includedir}/wx/plot/*
+%dir %{_includedir}/wx-*/wx/plot
+%{_includedir}/wx-*/wx/plot/*
 %{_libdir}/libwx_%{portname}*_plot*.so
 
-%dir %{_includedir}/wx/stc
-%{_includedir}/wx/stc/*
+%dir %{_includedir}/wx-*/wx/stc
+%{_includedir}/wx-*/wx/stc/*
 %{_libdir}/libwx_%{portname}*_stc*.so
 
-%dir %{_includedir}/wx/svg
-%{_includedir}/wx/svg/*
+%dir %{_includedir}/wx-*/wx/svg
+%{_includedir}/wx-*/wx/svg/*
 %{_libdir}/libwx_%{portname}*_svg*.so
 
-%dir %{_includedir}/wx/xrc
-%{_includedir}/wx/xrc/*
+%dir %{_includedir}/wx-*/wx/xrc
+%{_includedir}/wx-*/wx/xrc/*
 %{_libdir}/libwx_%{portname}*_xrc*.so