Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-root
Requires: %{wxbasename} = %{ver}
-#%if %{portname} == gtk2
-#BuildRequires: gtk+-2.0-devel
-#%else
-#BuildRequires: gtk+-devel >= 1.2.0
-#%endif
-#
-#BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
+%if %{portname} == gtk2
+BuildRequires: gtk+-2.0-devel
+%else
+BuildRequires: gtk+-devel >= 1.2.0
+%endif
+
+BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
# all packages providing an implementation of wxWidgets library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
wx/config.h
wx/convauto.h
wx/containr.h
+wx/cpp.h
wx/datetime.h
wx/datstrm.h
wx/dde.h
wx/features.h
wx/ffile.h
wx/file.h
+wx/fileback.h
wx/fileconf.h
wx/filefn.h
wx/filename.h
wx/mstream.h
wx/object.h
wx/platform.h
+wx/platinfo.h
wx/power.h
wx/process.h
wx/ptr_scpd.h
%{_includedir}/wx-%{ver2}/wx/confbase.h
%{_includedir}/wx-%{ver2}/wx/config.h
%{_includedir}/wx-%{ver2}/wx/containr.h
+%{_includedir}/wx-%{ver2}/wx/convauto.h
%{_includedir}/wx-%{ver2}/wx/datetime.h
%{_includedir}/wx-%{ver2}/wx/datstrm.h
%{_includedir}/wx-%{ver2}/wx/dde.h
%{_includedir}/wx-%{ver2}/wx/ipcbase.h
%{_includedir}/wx-%{ver2}/wx/isql.h
%{_includedir}/wx-%{ver2}/wx/isqlext.h
+%{_includedir}/wx-%{ver2}/wx/link.h
%{_includedir}/wx-%{ver2}/wx/list.h
%{_includedir}/wx-%{ver2}/wx/listimpl.cpp
%{_includedir}/wx-%{ver2}/wx/log.h
%{_includedir}/wx-%{ver2}/wx/mstream.h
%{_includedir}/wx-%{ver2}/wx/object.h
%{_includedir}/wx-%{ver2}/wx/platform.h
+%{_includedir}/wx-%{ver2}/wx/power.h
%{_includedir}/wx-%{ver2}/wx/process.h
%{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
+%{_includedir}/wx-%{ver2}/wx/recguard.h
%{_includedir}/wx-%{ver2}/wx/regex.h
%{_includedir}/wx-%{ver2}/wx/scopeguard.h
%{_includedir}/wx-%{ver2}/wx/snglinst.h
%{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
%{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
%{_includedir}/wx-%{ver2}/wx/unix/pipe.h
+%{_includedir}/wx-%{ver2}/wx/unix/private.h
%{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
%{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
EOF
# utils:
(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
+
%clean
rm -rf $RPM_BUILD_ROOT