%define _prefix /usr
-%define ver 2.7.0
-%define ver2 2.7
+%define ver 2.9.0
+%define ver2 2.9
%define rel 1
# Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-root
Requires: %{wxbasename} = %{ver}
-#%if %{portname} == gtk2
-#BuildRequires: gtk+-2.0-devel
-#%else
-#BuildRequires: gtk+-devel >= 1.2.0
-#%endif
-#
-#BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
+%if %{portname} == gtk2
+BuildRequires: gtk+-2.0-devel
+%else
+BuildRequires: gtk+-devel >= 1.2.0
+%endif
+
+BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
# all packages providing an implementation of wxWidgets library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
wx/beforestd.h
wx/buffer.h
wx/build.h
+wx/chartype.h
wx/chkconf.h
wx/clntdata.h
wx/cmdline.h
wx/config.h
wx/convauto.h
wx/containr.h
+wx/cpp.h
+wx/crt.h
wx/datetime.h
wx/datstrm.h
wx/dde.h
wx/event.h
wx/except.h
wx/features.h
+wx/flags.h
wx/ffile.h
wx/file.h
wx/fileconf.h
wx/filesys.h
wx/fontenc.h
wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
wx/fs_mem.h
wx/fs_zip.h
wx/hash.h
wx/mstream.h
wx/object.h
wx/platform.h
+wx/platinfo.h
wx/power.h
wx/process.h
wx/ptr_scpd.h
wx/strconv.h
wx/stream.h
wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
wx/sysopt.h
+wx/tarstrm.h
wx/textbuf.h
wx/textfile.h
wx/thread.h
wx/tokenzr.h
wx/txtstrm.h
wx/types.h
+wx/unichar.h
wx/uri.h
wx/utils.h
wx/variant.h
wx/wfstream.h
wx/wx.h
wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
wx/wxprec.h
wx/xti.h
wx/xtistrm.h
wx/zipstrm.h
wx/zstream.h
+wx/unix/app.h
wx/unix/apptbase.h
wx/unix/apptrait.h
wx/unix/execute.h
+wx/unix/evtloop.h
wx/unix/mimetype.h
wx/unix/pipe.h
wx/unix/private.h
# utils:
(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
+
%clean
rm -rf $RPM_BUILD_ROOT