Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-root
Requires: %{wxbasename} = %{ver}
-#%if %{portname} == gtk2
-#BuildRequires: gtk+-2.0-devel
-#%else
-#BuildRequires: gtk+-devel >= 1.2.0
-#%endif
-#
-#BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
+%if %{portname} == gtk2
+BuildRequires: gtk+-2.0-devel
+%else
+BuildRequires: gtk+-devel >= 1.2.0
+%endif
+
+BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
# all packages providing an implementation of wxWidgets library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
wx/config.h
wx/convauto.h
wx/containr.h
+wx/cpp.h
wx/datetime.h
wx/datstrm.h
wx/dde.h
wx/filesys.h
wx/fontenc.h
wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
wx/fs_mem.h
wx/fs_zip.h
wx/hash.h
wx/mstream.h
wx/object.h
wx/platform.h
+wx/platinfo.h
wx/power.h
wx/process.h
wx/ptr_scpd.h
wx/stream.h
wx/string.h
wx/sysopt.h
+wx/tarstrm.h
wx/textbuf.h
wx/textfile.h
wx/thread.h
# utils:
(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
+
%clean
rm -rf $RPM_BUILD_ROOT