]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Somehow the packinst.c and directory got removed from the archive, so I
[wxWidgets.git] / wxGTK.spec
index 254252822b0f6789e91a0757aa81fc48baf9604e..bc8734c2aeef758942a0ea95d850e551260b41bb 100644 (file)
@@ -1,7 +1,7 @@
 # Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.1.0
-%define rel 9
+%define ver 2.2.1
+%define rel 0
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -9,11 +9,9 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.0-b9.tgz
-URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
-Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-Requires: gtk+ >= 1.2.1
-BuildRoot: /tmp/wxgtk_root
+Source: wxGTK-%{ver}.tgz
+URL: http://wxwindows.org
+Packager: Robert Roebling <robert@roebling.de>
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
@@ -31,21 +29,30 @@ Group: X11/Libraries
 Requires: wxGTK
 
 %description devel
-Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
+Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package gl
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Group: X11/Libraries
+Requires: wxGTK
+
+%description gl
+OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
 %setup -n wxGTK
-./configure --prefix=%{pref} --enable-threads --disable-std_iostreams
+./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
-cd src && make
+if [ "$SMP" != "" ]; then
+  export MAKE="make -j$SMP"
+else
+  export MAKE="make"
+fi
+$MAKE
 
 %install
-rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
-
-%clean
-rm -rf $RPM_BUILD_ROOT
+make install
 
 %post
 /sbin/ldconfig
@@ -58,7 +65,8 @@ rm -rf $RPM_BUILD_ROOT
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
 %dir %{pref}/share/wx
 %{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk*
+%attr(755, -, -) %{pref}/lib/libwx_gtk.*
+%attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
 
 %files devel
 %defattr (644, root, root, 755)
@@ -66,5 +74,8 @@ rm -rf $RPM_BUILD_ROOT
 %{pref}/include/wx/*
 %dir %{pref}/lib/wx
 %{pref}/lib/wx/*
+%attr(755, -, -) %{pref}/bin/wxgtk-config
 %attr(755, -, -) %{pref}/bin/wx-config
 
+%files gl
+%attr(755, -, -) %{pref}/lib/libwx_gtk_gl*