]> git.saurik.com Git - wxWidgets.git/blobdiff - wxX11.spec
Updates
[wxWidgets.git] / wxX11.spec
index 7b49d8f5a6de363f39e5672e26882ee898b2700e..335e3eaba3e78248f7841a04ea729dde8ff68f26 100644 (file)
 %define pref /usr
-%define ver 2.5.4
-%define ver2 2.5
-%define rel 1
+%define ver  2.9.5
+%define ver2 2.9
+%define rel  1
 
 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
 %define unicode 0
 %{?_with_unicode: %{expand: %%define unicode 1}}
 %{?_without_unicode: %{expand: %%define unicode 0}}
 
-%define portname    x11
-%if %{unicode}
-%define name        wx-%{portname}-unicode
-%define wxbasename  wx-base-unicode
-%else 
-%define name        wx-%{portname}
-%define wxbasename  wx-base
-%endif
+%define portname x11univ
 
 %if %{unicode}
-%define wxconfigname wx%{portname}univu-%{ver2}-config
+    %define wxbasename   wx-base-unicode
+    %define name         wx-%{portname}-unicode
+    %define wxconfig     %{portname}-unicode-%{ver2}
+    %define wxconfiglink wx%{portname}u-%{ver2}-config
 %else
-%define wxconfigname wx%{portname}univ-%{ver2}-config
+    %define wxbasename   wx-base
+    %define name         wx-%{portname}
+    %define wxconfig     %{portname}-ansi-%{ver2}
+    %define wxconfiglink wx%{portname}-%{ver2}-config
 %endif
 
-Summary: The X11 port of the wxWindows library
-Name:    %{name}
+Summary: The X11 port of the wxWidgets library
+Name: %{name}
 Version: %{ver}
 Release: %{rel}
 License: wxWindows Licence
 Group: X11/Libraries
 Source: wxX11-%{ver}.tar.bz2
-URL: http://www.wxwindows.org
+URL: http://www.wxwidgets.org
 Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{pref}
-BuildRoot: /var/tmp/%{name}-root
+BuildRoot: %{_tmppath}/%{name}-root
+Requires: %{wxbasename} = %{ver}
 
-# all packages providing an implementation of wxWindows library (regardless of
+# all packages providing an implementation of wxWidgets library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
 Provides: wxwin
-
-# in addition, we should provide libwx_gtk as automatic generator only notices
-# libwx_gtk-%{ver}-%{rel}
-Provides: libwx_x11.so
-Provides: libwx_x11-%{ver2}.so
 Provides: wxX11
 
-Requires:      %{wxbasename} = %{ver}
-
 %description
-wxWindows is a free C++ library for cross-platform GUI development.
-With wxWindows, you can create applications for different GUIs (GTK+,
+wxWidgets is a free C++ library for cross-platform GUI development.
+With wxWidgets, you can create applications for different GUIs (GTK+,
 Motif/LessTif, MS Windows, Mac) from the same source code.
 
 %package devel
-Summary: The X11 port of the wxWindows library
+Summary: The X11 port of the wxWidgets library
 Group: X11/Libraries
 Requires: %{name} = %{ver}
 Requires: %{wxbasename}-devel = %{ver}
 
 %description devel
-Header files for wxX11, the X11 port of the wxWindows library.
+Header files for wxX11, the X11 port of the wxWidgets library.
 
 %package gl
-Summary: The X11 port of the wxWindows library, OpenGL add-on.
+Summary: The X11 port of the wxWidgets library, OpenGL add-on.
 Group: X11/Libraries
 Requires: %{name} = %{ver}
 
 %description gl
-OpenGL add-on library for wxX11, the X11 port of the wxWindows library.
+OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
 
 %package static
 Summary: wxX11 static libraries
 Group: Development/Libraries
+Requires: %{wxbasename}-static
+Requires: %{name}-devel = %{ver}
 
 %description static
 Static libraries for wxX11. You need them if you want to link statically against wxX11.
 
-%package contrib
-Summary: Contrib libraries for wxX11.
-Group: X11/Libraries
-Requires: %{name} = %{ver}
-
-%description contrib
-Contributed libraries for wxX11.
-
-%package contrib-devel
-Summary: Contrib libraries for wxX11.
-Group: X11/Libraries
-Requires: %{name}-contrib = %{ver}
-Requires: %{name}-devel = %{ver}
-
-%description contrib-devel
-Header files for contributed libraries for wxX11.
-
 %prep
 %setup -q -n wxX11-%{ver}
 
 %build
 if [ "$SMP" != "" ]; then
-  export MAKE="make -j$SMP"
+    export MAKE="make -j$SMP"
 else
-  export MAKE="make"
+    export MAKE="make"
 fi
 
 mkdir obj-shared
@@ -110,13 +88,10 @@ cd obj-shared
 %if %{unicode}
                               --enable-unicode \
 %else
-                              --with-odbc \
+                              --disable-unicode \
 %endif
-                              --with-opengl
 $MAKE
-cd contrib/src
-$MAKE
-cd ../../..
+cd ..
 
 mkdir obj-static
 cd obj-static
@@ -124,7 +99,7 @@ cd obj-static
 %if %{unicode}
                               --enable-unicode \
 %else
-                              --with-odbc \
+                              --disable-unicode \
 %endif
                               --with-opengl
 $MAKE
@@ -138,37 +113,50 @@ rm -rf $RPM_BUILD_ROOT
 # Remove headers that are part of wx-base-devel:
 
 # --- wxBase headers list begins here ---
-cat <<EOF >wxbase-headers-list
+cat <<EOF >wxbase-headers.files
 wx/afterstd.h
+wx/any.h
+wx/anystr.h
 wx/app.h
 wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
+wx/chartype.h
+wx/checkeddelete.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
+wx/convauto.h
 wx/containr.h
+wx/cpp.h
+wx/crt.h
 wx/datetime.h
-wx/datetime.inl
 wx/datstrm.h
 wx/dde.h
 wx/debug.h
 wx/defs.h
 wx/dir.h
 wx/dlimpexp.h
+wx/dlist.h
 wx/dynarray.h
 wx/dynlib.h
 wx/dynload.h
 wx/encconv.h
 wx/event.h
+wx/eventfilter.h
+wx/evtloop.h
 wx/except.h
 wx/features.h
+wx/flags.h
 wx/ffile.h
 wx/file.h
 wx/fileconf.h
@@ -177,6 +165,8 @@ wx/filename.h
 wx/filesys.h
 wx/fontenc.h
 wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
 wx/fs_mem.h
 wx/fs_zip.h
 wx/hash.h
@@ -190,8 +180,9 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
+wx/kbdstate.h
+wx/language.h
+wx/link.h
 wx/list.h
 wx/listimpl.cpp
 wx/log.h
@@ -202,92 +193,130 @@ wx/memory.h
 wx/memtext.h
 wx/mimetype.h
 wx/module.h
+wx/mousestate.h
 wx/msgout.h
-wx/msgout.h
+wx/msgqueue.h
 wx/mstream.h
+wx/numformatter.h
 wx/object.h
 wx/platform.h
+wx/platinfo.h
+wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
+wx/recguard.h
 wx/regex.h
+wx/rtti.h
+wx/scopedarray.h
+wx/scopedptr.h
 wx/scopeguard.h
+wx/sharedptr.h
 wx/snglinst.h
 wx/sstream.h
 wx/stack.h
 wx/stackwalk.h
 wx/stdpaths.h
+wx/stdstream.h
 wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
 wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
 wx/sysopt.h
+wx/tarstrm.h
 wx/textbuf.h
 wx/textfile.h
 wx/thread.h
 wx/thrimpl.cpp
+wx/time.h
 wx/timer.h
+wx/tls.h
 wx/tokenzr.h
+wx/tracker.h
+wx/translation.h
 wx/txtstrm.h
+wx/typeinfo.h
 wx/types.h
+wx/unichar.h
 wx/uri.h
+wx/ustring.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
+wx/versioninfo.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
+wx/xti2.h
 wx/xtistrm.h
+wx/xtictor.h
+wx/xtihandler.h
+wx/xtiprop.h
+wx/xtitypes.h
 wx/zipstrm.h
 wx/zstream.h
-wx/msw/apptrait.h
-wx/msw/apptbase.h
-wx/msw/chkconf.h
-wx/msw/crashrpt.h
-wx/msw/dde.h
-wx/msw/debughlp.h
-wx/msw/gccpriv.h
-wx/msw/mimetype.h
-wx/msw/stackwalk.h
-wx/msw/winundef.h
-wx/msw/wrapcctl.h
-wx/msw/wrapwin.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/implicitconversion.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/meta/pod.h
+wx/fswatcher.h
+wx/generic/fswatcher.h
+wx/unix/app.h
+wx/unix/apptbase.h
+wx/unix/apptrait.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
+wx/unix/evtloopsrc.h
+wx/unix/pipe.h
+wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/tls.h
+wx/unix/fswatcher_kqueue.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/fswatcher_inotify.h
 wx/fs_inet.h
-wx/gsocket.h
 wx/protocol/file.h
 wx/protocol/ftp.h
 wx/protocol/http.h
+wx/protocol/log.h
 wx/protocol/protocol.h
 wx/sckaddr.h
 wx/sckipc.h
 wx/sckstrm.h
 wx/socket.h
 wx/url.h
-wx/msw/gsockmsw.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
-  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
+  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
 done
 
 # list of all core headers:
-find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
-
-# contrib stuff:
-(cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
-(cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
+find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
 
 # remove wxBase files so that RPM doesn't complain about unpackaged files:
 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
+%if %{unicode}
+    rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
+%endif
 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
 
@@ -300,96 +329,61 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 /sbin/ldconfig
 
+%post devel
+# link wx-config when you install RPM.
+ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
+# link wx-config with explicit name.
+ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
+/sbin/ldconfig
+
+%postun devel
+/sbin/ldconfig
+
+%preun devel
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+    SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
+    SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+    if test "x$SUM1" = "x$SUM2" ; then
+        rm -f %{_bindir}/wx-config
+    fi
+fi
+rm -f %{_bindir}/%{wxconfiglink}
+
 %post gl
 /sbin/ldconfig
 
 %postun gl
 /sbin/ldconfig
 
-
 %files
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
-%{_libdir}/libwx_%{portname}*_core*.so.*
-%{_libdir}/libwx_%{portname}*_html*.so.*
-%{_libdir}/libwx_%{portname}*_adv*.so.*
-%if !%{unicode}
-%{_libdir}/libwx_%{portname}*_dbgrid*.so.*
-%endif
+%{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
+%{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
+%{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
+%{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
+%{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
+%{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
+
 
 %files devel -f core-headers.files
 %defattr(-,root,root)
-%{_libdir}/libwx_%{portname}*_core*.so
-%{_libdir}/libwx_%{portname}*_html*.so
-%{_libdir}/libwx_%{portname}*_adv*.so
-%if !%{unicode}
-%{_libdir}/libwx_%{portname}*_dbgrid*.so
-%endif
-%{_libdir}/libwx_%{portname}*_gl*.so
+%{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_core-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_html-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_media-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
+%{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
-%{_bindir}/%{wxconfigname}
+%{_bindir}/wxrc*
 
 %files gl
 %defattr(-,root,root)
-%{_libdir}/libwx_%{portname}*_gl*.so.*
+%{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
 
 %files static
 %defattr (-,root,root)
-%{_libdir}/libwx_%{portname}*.a
+%{_libdir}/libwx_%{portname}*_*-%{ver2}.a
 
-%files contrib
-%defattr(-,root,root)
-%{_libdir}/libwx_%{portname}*_animate*.so.*
-%{_libdir}/libwx_%{portname}*_deprecated*.so.*
-%{_libdir}/libwx_%{portname}*_fl*.so.*
-%{_libdir}/libwx_%{portname}*_gizmos*.so.*
-%{_libdir}/libwx_%{portname}*_mmedia*.so.*
-%{_libdir}/libwx_%{portname}*_ogl*.so.*
-%{_libdir}/libwx_%{portname}*_plot*.so.*
-%{_libdir}/libwx_%{portname}*_stc*.so.*
-%{_libdir}/libwx_%{portname}*_svg*.so.*
-%{_libdir}/libwx_%{portname}*_xrc*.so.*
-
-%files contrib-devel
-%defattr(-,root,root)
-%{_bindir}/wxrc
-%dir %{_includedir}/wx-*/wx/animate
-%{_includedir}/wx-*/wx/animate/*
-%{_libdir}/libwx_%{portname}*_animate*.so
-
-%dir %{_includedir}/wx-*/wx/deprecated
-%{_includedir}/wx-*/wx/deprecated/*
-%{_libdir}/libwx_%{portname}*_deprecated*.so
-
-%dir %{_includedir}/wx-*/wx/fl
-%{_includedir}/wx-*/wx/fl/*
-%{_libdir}/libwx_%{portname}*_fl*.so
-
-%dir %{_includedir}/wx-*/wx/gizmos
-%{_includedir}/wx-*/wx/gizmos/*
-%{_libdir}/libwx_%{portname}*_gizmos*.so
-
-%dir %{_includedir}/wx-*/wx/mmedia
-%{_includedir}/wx-*/wx/mmedia/*
-%{_libdir}/libwx_%{portname}*_mmedia*.so
-
-%dir %{_includedir}/wx-*/wx/ogl
-%{_includedir}/wx-*/wx/ogl/*
-%{_libdir}/libwx_%{portname}*_ogl*.so
-
-%dir %{_includedir}/wx-*/wx/plot
-%{_includedir}/wx-*/wx/plot/*
-%{_libdir}/libwx_%{portname}*_plot*.so
-
-%dir %{_includedir}/wx-*/wx/stc
-%{_includedir}/wx-*/wx/stc/*
-%{_libdir}/libwx_%{portname}*_stc*.so
-
-%dir %{_includedir}/wx-*/wx/svg
-%{_includedir}/wx-*/wx/svg/*
-%{_libdir}/libwx_%{portname}*_svg*.so
-
-%dir %{_includedir}/wx-*/wx/xrc
-%{_includedir}/wx-*/wx/xrc/*
-%{_libdir}/libwx_%{portname}*_xrc*.so