+install-gtk-py-lib: DH_OPTIONS=-p$(package_gtk_py_lib)
+install-gtk-py-lib: build-gtk-py-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cd wxPython \
+ && $(python_ver) ./setup.py install \
+ --prefix=`pwd`/../debian/$(package_gtk_py_lib)/usr \
+ WX_CONFIG='$(wxconfig)' \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ FLAVOUR=$(DEBIAN_WXFLAVOUR)
+
+ find debian/$(package_gtk_py_lib)/$(pydir) -name '*.py?' -exec rm '{}' ';'
+
+ # This is rather bogus, its included in the main copyright file now though.
+ rm -f debian/$(package_gtk_py_lib)/$(wxpydir)/wx/tools/XRCed/license.txt
+
+install-gtk-py: DH_OPTIONS=-p$(package_gtk_py)
+install-gtk-py: install-gtk-py-lib
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) \
+ usr/bin \
+ $(pydir)/{wxversion.py,wx.pth}
+ rm -r debian/$(package_gtk_py_lib)/usr/bin
+
+ dh_installman debian/wxPython-tools.1
+ dh_link usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2py.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2xpm.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2png.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pycrust.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyshell.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/xrced.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/helpviewer.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalacarte.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalamode.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywrap.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywxrc.1
+
+
+install-common: DH_OPTIONS=-p$(package_common)
+install-common: install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+# We don't need the afm metrics for gtk2, but we might need them to support
+# the 2.4 release for a while still and any other ports we might build.
+ dh_install $(objdir_gtk_install)/share/wx usr/share
+ dh_install $(objdir_gtk_install)/share/aclocal usr/share
+ dh_installman debian/wx-config.1
+
+ dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
+# dh_install $(objdir_gtk_shared)/contrib/utils/wxrcedit/wxrcedit usr/bin
+
+ dh_installman debian/wxrc-tools.1
+ dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrc.1
+# dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrcedit.1
+
+
+install-headers: DH_OPTIONS=-p$(package_headers)
+install-headers: install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+# The only way to be really sure we get the univ headers correct is to install
+# them. Do that in a scratch dirs, and move the gtk ones last, so at least
+# they win in the result of any uncaught conflict.
+
+# cd $(objdir_gtk_univ) \
+# && $(MAKE) install prefix=`pwd`/../$(objdir_univ_install)/usr
+
+# dh_movefiles --sourcedir=$(objdir_univ_install)
+ dh_install $(objdir_gtk_install)/include usr
+
+install-i18n: DH_OPTIONS=-p$(package_i18n)
+install-i18n: build-i18n-stamp install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_install $(objdir_gtk_install)/share/locale usr/share
+
+install-doc: DH_OPTIONS=-p$(package_doc)
+install-doc: build-doc-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs