]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMotif.spec
ckconf
[wxWidgets.git] / wxMotif.spec
index 17b1ff4dfc863f20132d3334cd94c6df00a63a72..dfe7d96d11d05e4f35569502585bb86920a78164 100644 (file)
@@ -1,9 +1,5 @@
-# RPM .spec file for wxMotif. Based on the .spec file for wxGTK
-# (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
-
-# Note that this is NOT a relocatable package
 %define pref /usr
 %define pref /usr
-%define ver 2.5.0
+%define ver 2.5.3
 %define ver2 2.5
 %define rel 1
 
 %define ver2 2.5
 %define rel 1
 
@@ -19,8 +15,8 @@ Release: %{rel}
 License: wxWindows Licence
 Group: X11/Libraries
 Source: wxMOTIF-%{ver}.tar.bz2
 License: wxWindows Licence
 Group: X11/Libraries
 Source: wxMOTIF-%{ver}.tar.bz2
-URL: http://www.wxwindows.org
-Packager: Robert Fendt <rfendt@myokay.net>
+URL: http://www.wxwidgets.org
+Packager: wxWindows developers <wx-dev@lists.wxwidgets.org>
 BuildRoot: /tmp/wxmotif_root
 
 # all packages providing an implementation of wxWindows library (regardless of
 BuildRoot: /tmp/wxmotif_root
 
 # all packages providing an implementation of wxWindows library (regardless of
@@ -31,7 +27,6 @@ Provides: wxwin
 Provides: wxMotif
 
 Requires:      %{wxbasename} = %{ver}
 Provides: wxMotif
 
 Requires:      %{wxbasename} = %{ver}
-BuildRequires: %{wxbasename}-devel = %{ver}
 
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
 
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
@@ -90,16 +85,152 @@ rm -rf $RPM_BUILD_ROOT
 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
 # Remove headers that are part of wx-base-devel:
 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
 
 # Remove headers that are part of wx-base-devel:
-(
-cd $RPM_BUILD_ROOT
-for f in  `rpm -ql %{wxbasename}-devel | sed -e 's,\(.*\),.\1,g'` ; do
-  if test -f $f ; then rm -f $f ; fi
+
+# --- wxBase headers list begins here ---
+cat <<EOF >wxbase-headers-list
+wx/afterstd.h
+wx/app.h
+wx/apptrait.h
+wx/arrimpl.cpp
+wx/arrstr.h
+wx/beforestd.h
+wx/buffer.h
+wx/build.h
+wx/chkconf.h
+wx/clntdata.h
+wx/cmdline.h
+wx/confbase.h
+wx/config.h
+wx/containr.h
+wx/datetime.h
+wx/datetime.inl
+wx/datstrm.h
+wx/dde.h
+wx/debug.h
+wx/defs.h
+wx/dir.h
+wx/dlimpexp.h
+wx/dynarray.h
+wx/dynlib.h
+wx/dynload.h
+wx/encconv.h
+wx/event.h
+wx/except.h
+wx/features.h
+wx/ffile.h
+wx/file.h
+wx/fileconf.h
+wx/filefn.h
+wx/filename.h
+wx/filesys.h
+wx/fontenc.h
+wx/fontmap.h
+wx/fs_mem.h
+wx/fs_zip.h
+wx/hash.h
+wx/hashmap.h
+wx/hashset.h
+wx/iconloc.h
+wx/init.h
+wx/intl.h
+wx/iosfwrap.h
+wx/ioswrap.h
+wx/ipc.h
+wx/ipcbase.h
+wx/isql.h
+wx/isqlext.h
+wx/list.h
+wx/listimpl.cpp
+wx/log.h
+wx/longlong.h
+wx/math.h
+wx/memconf.h
+wx/memory.h
+wx/memtext.h
+wx/mimetype.h
+wx/module.h
+wx/msgout.h
+wx/msgout.h
+wx/mstream.h
+wx/object.h
+wx/platform.h
+wx/process.h
+wx/ptr_scpd.h
+wx/regex.h
+wx/scopeguard.h
+wx/snglinst.h
+wx/sstream.h
+wx/stack.h
+wx/stdpaths.h
+wx/stockitem.h
+wx/stopwatch.h
+wx/strconv.h
+wx/stream.h
+wx/string.h
+wx/sysopt.h
+wx/textbuf.h
+wx/textfile.h
+wx/thread.h
+wx/thrimpl.cpp
+wx/timer.h
+wx/tokenzr.h
+wx/txtstrm.h
+wx/types.h
+wx/uri.h
+wx/utils.h
+wx/variant.h
+wx/vector.h
+wx/version.h
+wx/volume.h
+wx/wfstream.h
+wx/wx.h
+wx/wxchar.h
+wx/wxprec.h
+wx/xti.h
+wx/xtistrm.h
+wx/zipstrm.h
+wx/zstream.h
+wx/msw/apptrait.h
+wx/msw/apptbase.h
+wx/msw/chkconf.h
+wx/msw/crashrpt.h
+wx/msw/dde.h
+wx/msw/gccpriv.h
+wx/msw/mimetype.h
+wx/msw/winundef.h
+wx/msw/wrapcctl.h
+wx/msw/wrapwin.h
+wx/fs_inet.h
+wx/gsocket.h
+wx/protocol/file.h
+wx/protocol/ftp.h
+wx/protocol/http.h
+wx/protocol/protocol.h
+wx/sckaddr.h
+wx/sckipc.h
+wx/sckstrm.h
+wx/socket.h
+wx/url.h
+wx/msw/gsockmsw.h
+wx/xml/xml.h
+wx/xtixml.h
+wx/db.h
+wx/dbkeyg.h
+wx/dbtable.h
+EOF
+# --- wxBase headers list ends here ---
+for f in `cat wxbase-headers-list` ; do
+  rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
 done
 done
-)
 
 # list of all core headers:
 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
 
 
 # list of all core headers:
 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
 
+# remove wxBase files so that RPM doesn't complain about unpackaged files:
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
+rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
+rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -116,22 +247,6 @@ rm -rf $RPM_BUILD_ROOT
 %postun gl
 /sbin/ldconfig
 
 %postun gl
 /sbin/ldconfig
 
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
-    ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
-  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
-  if test "x$SUM1" = "x$SUM2" ; then
-    rm -f %{_bindir}/wx-config
-  fi
-fi
-
 
 %files
 %defattr(-,root,root)
 
 %files
 %defattr(-,root,root)
@@ -161,3 +276,4 @@ fi
 %files static
 %defattr (-,root,root)
 %{_libdir}/libwx_%{portname}*.a
 %files static
 %defattr (-,root,root)
 %{_libdir}/libwx_%{portname}*.a
+