]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
removed obsolete build files which are likely to confuse more than help people now
[wxWidgets.git] / wxGTK.spec
index eda78cfe20a1b8c2880bb7f0659b2208d221c4e9..2a601478eece2c92f6240bc4b5ffae7c3bff72df 100644 (file)
@@ -61,13 +61,13 @@ Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{_prefix}
 BuildRoot: %{_tmppath}/%{name}-root
 Requires: %{wxbasename} = %{ver}
-#%if %{portname} == gtk2
-#BuildRequires: gtk+-2.0-devel
-#%else
-#BuildRequires: gtk+-devel >= 1.2.0
-#%endif
-#
-#BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
+%if %{portname} == gtk2
+BuildRequires: gtk+-2.0-devel
+%else
+BuildRequires: gtk+-devel >= 1.2.0
+%endif
+
+BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
 
 # all packages providing an implementation of wxWidgets library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
@@ -275,6 +275,7 @@ wx/msgout.h
 wx/mstream.h
 wx/object.h
 wx/platform.h
+wx/platinfo.h
 wx/power.h
 wx/process.h
 wx/ptr_scpd.h
@@ -357,6 +358,7 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/confbase.h
 %{_includedir}/wx-%{ver2}/wx/config.h
 %{_includedir}/wx-%{ver2}/wx/containr.h
+%{_includedir}/wx-%{ver2}/wx/convauto.h
 %{_includedir}/wx-%{ver2}/wx/datetime.h
 %{_includedir}/wx-%{ver2}/wx/datstrm.h
 %{_includedir}/wx-%{ver2}/wx/dde.h
@@ -394,6 +396,7 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
 %{_includedir}/wx-%{ver2}/wx/isql.h
 %{_includedir}/wx-%{ver2}/wx/isqlext.h
+%{_includedir}/wx-%{ver2}/wx/link.h
 %{_includedir}/wx-%{ver2}/wx/list.h
 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
 %{_includedir}/wx-%{ver2}/wx/log.h
@@ -408,8 +411,10 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/mstream.h
 %{_includedir}/wx-%{ver2}/wx/object.h
 %{_includedir}/wx-%{ver2}/wx/platform.h
+%{_includedir}/wx-%{ver2}/wx/power.h
 %{_includedir}/wx-%{ver2}/wx/process.h
 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
+%{_includedir}/wx-%{ver2}/wx/recguard.h
 %{_includedir}/wx-%{ver2}/wx/regex.h
 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
 %{_includedir}/wx-%{ver2}/wx/snglinst.h
@@ -467,6 +472,7 @@ cat <<EOF >wxbase-headers.paths
 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
+%{_includedir}/wx-%{ver2}/wx/unix/private.h
 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
 EOF
@@ -485,8 +491,14 @@ cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
 rm -rf $RPM_BUILD_ROOT/_save_dir
 
 # contrib stuff:
-(cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
+(cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+(cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+
+# utils:
+(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -554,6 +566,7 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
 %if !%{unicode}
     %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
@@ -561,6 +574,7 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
 
 %files -n wx-i18n
@@ -571,6 +585,7 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %defattr(-,root,root)
 # shared libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
 %if !%{unicode}
     %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
@@ -579,9 +594,11 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
 # static libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
 %if !%{unicode}
     %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
@@ -589,6 +606,7 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
 %dir %{_libdir}/wx
 %{_libdir}/wx/config/%{wxconfig}
@@ -630,6 +648,18 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
 
+# static libs
+%{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
+
 %files contrib-devel
 %defattr(-,root,root)
 %dir %{_includedir}/wx-%{ver2}/wx/animate