]> git.saurik.com Git - wxWidgets.git/blobdiff - wxBase.spec
Applied patch #514037 from Paul Gammans to remove unneeded code in wxDbGridTableBase...
[wxWidgets.git] / wxBase.spec
index 7c5b95e99392f4670d182adf2914fecacd19f316..5b38f95a9b180581060b55ae8a20923395344918 100644 (file)
@@ -1,5 +1,6 @@
 %define pref /usr
-%define ver 2.3.1
+%define ver 2.3.2
+%define ver2 2.3
 %define rel 1
 
 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
@@ -26,14 +27,20 @@ the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
 %package devel
 Summary: wxBase headers needed for developping with wxBase
 Group: Development/Libraries
-Requires: wxBase
+Requires: wxBase = %{ver}
 
 %description devel
 Header files for wxBase. You need them to develop programs using wxBase.
 
+%package static
+Summary: wxBase static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxBase. You need them if you want to link statically against wxBase.
+
 %prep
 %setup -n wxBase-%{ver}
-./configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
 
 %build
 if [ "$SMP" != "" ]; then
@@ -41,11 +48,25 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
+$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
 $MAKE
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -56,18 +77,37 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 /sbin/ldconfig
 
-%files
-%defattr (644, root, root, 755)
-%doc COPYING.LIB LICENCE.txt README.txt SYMBOLS.txt
-%attr(755, -, -) %{pref}/lib/libwx_base*
-
-%files devel -f src/rpmfiles.lst
-%dir %{pref}/lib/wx
-%dir %{pref}/lib/wx/include
-%dir %{pref}/lib/wx/include/wx
-%dir %{pref}/lib/wx/include/wx/base
-%{pref}/lib/wx/include/wx/base/setup.h
-%defattr (644, root, root, 755)
-%attr(755, -, -) %{pref}/bin/wxbase-config
-%attr(755, -, -) %{pref}/bin/wx-config
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+    ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+  SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
+  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+  if test "x$SUM1" = "x$SUM2" ; then
+    rm -f %{_bindir}/wx-config
+  fi
+fi
+
+%files -f wxstd.lang
+%defattr (-,root,root)
+%doc COPYING.LIB *.txt
+%{_libdir}/libwx_base*so.*
+
+%files devel
+%defattr (-,root,root)
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%{_libdir}/libwx_base*.so
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxbase-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a