]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
fix GCC warning about not explicitly initializing base class
[wxWidgets.git] / wxGTK.spec
index 5a6a90699d9fcfd82055d9b5c6601547169851fe..98cc171f09e1ce8a8a67cd0fa5320f0338cdea25 100644 (file)
@@ -1,6 +1,6 @@
-%define _prefix /opt/gnome
-%define ver  2.6.2
-%define ver2 2.6
+%define _prefix /usr
+%define ver  2.9.2
+%define ver2 2.9
 %define rel  1
 
 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
 
 %if %{unicode}
     %define name               wx-%{portname}-unicode
-    %define wxconfig           %{portname}-unicode-release-%{ver2}
-    %define wxconfigstatic     %{portname}-unicode-release-static-%{ver2}
+    %define wxconfig           %{portname}-unicode-%{ver2}
+    %define wxconfigstatic     %{portname}-unicode-static-%{ver2}
     %define wxconfiglink       wx%{portname}u-%{ver2}-config
 %else
     %define name               wx-%{portname}-ansi
-    %define wxconfig           %{portname}-ansi-release-%{ver2}
-    %define wxconfigstatic     %{portname}-ansi-release-static-%{ver2}
+    %define wxconfig           %{portname}-ansi-%{ver2}
+    %define wxconfigstatic     %{portname}-ansi-static-%{ver2}
     %define wxconfiglink       wx%{portname}-%{ver2}-config
 %endif
 
 %if %{unicode}
     %define wxbasename         wx-base-unicode
-    %define wxbaseconfig       base-unicode-release-%{ver2}
-    %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
+    %define wxbaseconfig       base-unicode-%{ver2}
     %define wxbaseconfiglink   wxbaseu-%{ver2}-config
 %else
     %define wxbasename         wx-base-ansi
-    %define wxbaseconfig       base-ansi-release-%{ver2}
-    %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
+    %define wxbaseconfig       base-ansi-%{ver2}
     %define wxbaseconfiglink   wxbase-%{ver2}-config
 %endif
 
@@ -57,16 +55,16 @@ Version: %{ver}
 Release: %{rel}
 License: wxWindows Licence
 Group: X11/Libraries
-Source: wxGTK-%{ver}.tar.gz
+Source: wxGTK-%{ver}.tar.bz2
 URL: http://www.wxwidgets.org
 Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{_prefix}
 BuildRoot: %{_tmppath}/%{name}-root
 Requires: %{wxbasename} = %{ver}
 %if %{portname} == gtk2
-# BuildRequires: gtk+-2.0-devel
+BuildRequires: gtk2-devel
 %else
-BuildRequires: gtk+-devel >= 1.2.0
+BuildRequires: gtk+-devel >= 1.2.0
 %endif
 
 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
@@ -118,7 +116,7 @@ wxBase is a collection of C++ classes providing basic data structures (strings,
 lists, arrays), portable wrappers around many OS-specific funstions (file
 operations, time/date manipulations, threads, processes, sockets, shared
 library loading) as well as other utility classes (streams, archive and
-compression). wxBase currently supports Win32, most Unix variants (Linux, 
+compression). wxBase currently supports Win32, most Unix variants (Linux,
 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
 
 %package -n %{wxbasename}-devel
@@ -130,23 +128,6 @@ Provides: wxBase-devel
 wxBase library - non-GUI support classes of the wxWidgets toolkit,
 header files.
 
-%package contrib
-Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
-Group: X11/Libraries
-Requires: %{name} = %{ver}
-
-%description contrib
-Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
-
-%package contrib-devel
-Summary: The GTK+ %{gtkver} port of the wxWidgets library
-Group: X11/Libraries
-Requires: %{name}-contrib = %{ver}
-Requires: %{name}-devel = %{ver}
-
-%description contrib-devel
-Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
-
 %prep
 %setup -q -n wxGTK-%{ver}
 
@@ -157,21 +138,9 @@ else
     export MAKE="make"
 fi
 
-mkdir obj-shared-no-gui
-cd obj-shared-no-gui
-../configure --prefix=%{_prefix} \
-                             --disable-gui \
-%if %{unicode}
-                              --enable-unicode
-%else
-                              --disable-unicode
-%endif
-$MAKE
-cd ..
-
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{_prefix} \
+../configure --prefix=%{_prefix} --libdir=%{_libdir} \
 %if ! %{gtk2}
                              --with-gtk=1 \
 %else
@@ -181,31 +150,17 @@ cd obj-shared
                              --enable-unicode \
 %else
                              --disable-unicode \
-                             --with-odbc \
 %endif
-                             --with-opengl
-$MAKE
-
-cd contrib/src
+                             --with-opengl \
+                             --with-gnomeprint \
+                             --enable-mediactrl
 $MAKE
-cd ../../..
 
-mkdir obj-static-no-gui
-cd obj-static-no-gui
-../configure --prefix=%{_prefix} \
-                             --disable-gui \
-                             --disable-shared \
-%if %{unicode}
-                              --enable-unicode
-%else
-                              --disable-unicode
-%endif
-$MAKE
 cd ..
 
 mkdir obj-static
 cd obj-static
-../configure --prefix=%{_prefix} \
+../configure --prefix=%{_prefix} --libdir=%{_libdir} \
 %if ! %{gtk2}
                              --with-gtk=1 \
 %else
@@ -213,43 +168,51 @@ cd obj-static
 %endif
                              --disable-shared \
 %if %{unicode}
-                             --enable-unicode \
+                             --enable-unicode \
 %else
-                             --disable-unicode \
-                             --with-odbc \
+                             --disable-unicode \
 %endif
-                             --with-opengl
+                             --with-opengl \
+                             --with-gnomeprint \
+                             --enable-mediactrl
 $MAKE
 
-cd contrib/src
-$MAKE
-cd ../../..
+cd ..
+
+make -C locale allmo
 
 %install
 rm -rf $RPM_BUILD_ROOT
-(cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
+(cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+(cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
 
 # --- wxBase headers list begins here ---
 cat <<EOF >wxbase-headers.files
 wx/afterstd.h
+wx/any.h
+wx/anystr.h
 wx/app.h
 wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
+wx/chartype.h
+wx/checkeddelete.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
 wx/convauto.h
 wx/containr.h
+wx/cpp.h
+wx/crt.h
 wx/datetime.h
 wx/datstrm.h
 wx/dde.h
@@ -257,13 +220,16 @@ wx/debug.h
 wx/defs.h
 wx/dir.h
 wx/dlimpexp.h
+wx/dlist.h
 wx/dynarray.h
 wx/dynlib.h
 wx/dynload.h
 wx/encconv.h
 wx/event.h
+wx/evtloop.h
 wx/except.h
 wx/features.h
+wx/flags.h
 wx/ffile.h
 wx/file.h
 wx/fileconf.h
@@ -272,6 +238,8 @@ wx/filename.h
 wx/filesys.h
 wx/fontenc.h
 wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
 wx/fs_mem.h
 wx/fs_zip.h
 wx/hash.h
@@ -285,8 +253,8 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
+wx/kbdstate.h
+wx/language.h
 wx/link.h
 wx/list.h
 wx/listimpl.cpp
@@ -298,208 +266,120 @@ wx/memory.h
 wx/memtext.h
 wx/mimetype.h
 wx/module.h
+wx/mousestate.h
 wx/msgout.h
+wx/msgqueue.h
 wx/mstream.h
 wx/object.h
 wx/platform.h
+wx/platinfo.h
 wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
 wx/recguard.h
 wx/regex.h
+wx/rtti.h
+wx/scopedarray.h
+wx/scopedptr.h
 wx/scopeguard.h
+wx/sharedptr.h
 wx/snglinst.h
 wx/sstream.h
 wx/stack.h
 wx/stackwalk.h
 wx/stdpaths.h
+wx/stdstream.h
 wx/stockitem.h
 wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
 wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
 wx/sysopt.h
+wx/tarstrm.h
 wx/textbuf.h
 wx/textfile.h
 wx/thread.h
 wx/thrimpl.cpp
 wx/timer.h
+wx/tls.h
 wx/tokenzr.h
+wx/tracker.h
+wx/translation.h
 wx/txtstrm.h
+wx/typeinfo.h
 wx/types.h
+wx/unichar.h
 wx/uri.h
+wx/ustring.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
+wx/versioninfo.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
 wx/xtistrm.h
+wx/xtictor.h
+wx/xtihandler.h
+wx/xtiprop.h
+wx/xtitypes.h
 wx/zipstrm.h
 wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/implicitconversion.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/meta/pod.h
+wx/fswatcher.h
+wx/generic/fswatcher.h
+wx/unix/app.h
 wx/unix/apptbase.h
 wx/unix/apptrait.h
-wx/unix/execute.h
-wx/unix/mimetype.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
+wx/unix/evtloopsrc.h
 wx/unix/pipe.h
-wx/unix/private.h
-wx/unix/stackwalk.h
 wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/tls.h
+wx/unix/fswatcher_kqueue.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/fswatcher_inotify.h
 wx/fs_inet.h
-wx/gsocket.h
 wx/protocol/file.h
 wx/protocol/ftp.h
 wx/protocol/http.h
+wx/protocol/log.h
 wx/protocol/protocol.h
 wx/sckaddr.h
 wx/sckipc.h
 wx/sckstrm.h
 wx/socket.h
 wx/url.h
-wx/unix/gsockunx.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
-EOF
-# --- wxBase headers list ends here ---
-cat <<EOF >wxbase-headers.paths
-%{_includedir}/wx-%{ver2}/wx/afterstd.h
-%{_includedir}/wx-%{ver2}/wx/app.h
-%{_includedir}/wx-%{ver2}/wx/apptrait.h
-%{_includedir}/wx-%{ver2}/wx/archive.h
-%{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
-%{_includedir}/wx-%{ver2}/wx/arrstr.h
-%{_includedir}/wx-%{ver2}/wx/beforestd.h
-%{_includedir}/wx-%{ver2}/wx/buffer.h
-%{_includedir}/wx-%{ver2}/wx/build.h
-%{_includedir}/wx-%{ver2}/wx/chkconf.h
-%{_includedir}/wx-%{ver2}/wx/clntdata.h
-%{_includedir}/wx-%{ver2}/wx/cmdline.h
-%{_includedir}/wx-%{ver2}/wx/confbase.h
-%{_includedir}/wx-%{ver2}/wx/config.h
-%{_includedir}/wx-%{ver2}/wx/containr.h
-%{_includedir}/wx-%{ver2}/wx/datetime.h
-%{_includedir}/wx-%{ver2}/wx/datetime.inl
-%{_includedir}/wx-%{ver2}/wx/datstrm.h
-%{_includedir}/wx-%{ver2}/wx/dde.h
-%{_includedir}/wx-%{ver2}/wx/debug.h
-%{_includedir}/wx-%{ver2}/wx/defs.h
-%{_includedir}/wx-%{ver2}/wx/dir.h
-%{_includedir}/wx-%{ver2}/wx/dlimpexp.h
-%{_includedir}/wx-%{ver2}/wx/dynarray.h
-%{_includedir}/wx-%{ver2}/wx/dynlib.h
-%{_includedir}/wx-%{ver2}/wx/dynload.h
-%{_includedir}/wx-%{ver2}/wx/encconv.h
-%{_includedir}/wx-%{ver2}/wx/event.h
-%{_includedir}/wx-%{ver2}/wx/except.h
-%{_includedir}/wx-%{ver2}/wx/features.h
-%{_includedir}/wx-%{ver2}/wx/ffile.h
-%{_includedir}/wx-%{ver2}/wx/file.h
-%{_includedir}/wx-%{ver2}/wx/fileconf.h
-%{_includedir}/wx-%{ver2}/wx/filefn.h
-%{_includedir}/wx-%{ver2}/wx/filename.h
-%{_includedir}/wx-%{ver2}/wx/filesys.h
-%{_includedir}/wx-%{ver2}/wx/fontenc.h
-%{_includedir}/wx-%{ver2}/wx/fontmap.h
-%{_includedir}/wx-%{ver2}/wx/fs_mem.h
-%{_includedir}/wx-%{ver2}/wx/fs_zip.h
-%{_includedir}/wx-%{ver2}/wx/hash.h
-%{_includedir}/wx-%{ver2}/wx/hashmap.h
-%{_includedir}/wx-%{ver2}/wx/hashset.h
-%{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
-%{_includedir}/wx-%{ver2}/wx/iconloc.h
-%{_includedir}/wx-%{ver2}/wx/init.h
-%{_includedir}/wx-%{ver2}/wx/intl.h
-%{_includedir}/wx-%{ver2}/wx/iosfwrap.h
-%{_includedir}/wx-%{ver2}/wx/ioswrap.h
-%{_includedir}/wx-%{ver2}/wx/ipc.h
-%{_includedir}/wx-%{ver2}/wx/ipcbase.h
-%{_includedir}/wx-%{ver2}/wx/isql.h
-%{_includedir}/wx-%{ver2}/wx/isqlext.h
-%{_includedir}/wx-%{ver2}/wx/list.h
-%{_includedir}/wx-%{ver2}/wx/listimpl.cpp
-%{_includedir}/wx-%{ver2}/wx/log.h
-%{_includedir}/wx-%{ver2}/wx/longlong.h
-%{_includedir}/wx-%{ver2}/wx/math.h
-%{_includedir}/wx-%{ver2}/wx/memconf.h
-%{_includedir}/wx-%{ver2}/wx/memory.h
-%{_includedir}/wx-%{ver2}/wx/memtext.h
-%{_includedir}/wx-%{ver2}/wx/mimetype.h
-%{_includedir}/wx-%{ver2}/wx/module.h
-%{_includedir}/wx-%{ver2}/wx/msgout.h
-%{_includedir}/wx-%{ver2}/wx/mstream.h
-%{_includedir}/wx-%{ver2}/wx/object.h
-%{_includedir}/wx-%{ver2}/wx/platform.h
-%{_includedir}/wx-%{ver2}/wx/process.h
-%{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
-%{_includedir}/wx-%{ver2}/wx/regex.h
-%{_includedir}/wx-%{ver2}/wx/scopeguard.h
-%{_includedir}/wx-%{ver2}/wx/snglinst.h
-%{_includedir}/wx-%{ver2}/wx/sstream.h
-%{_includedir}/wx-%{ver2}/wx/stack.h
-%{_includedir}/wx-%{ver2}/wx/stackwalk.h
-%{_includedir}/wx-%{ver2}/wx/stdpaths.h
-%{_includedir}/wx-%{ver2}/wx/stockitem.h
-%{_includedir}/wx-%{ver2}/wx/stopwatch.h
-%{_includedir}/wx-%{ver2}/wx/strconv.h
-%{_includedir}/wx-%{ver2}/wx/stream.h
-%{_includedir}/wx-%{ver2}/wx/string.h
-%{_includedir}/wx-%{ver2}/wx/sysopt.h
-%{_includedir}/wx-%{ver2}/wx/textbuf.h
-%{_includedir}/wx-%{ver2}/wx/textfile.h
-%{_includedir}/wx-%{ver2}/wx/thread.h
-%{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
-%{_includedir}/wx-%{ver2}/wx/timer.h
-%{_includedir}/wx-%{ver2}/wx/tokenzr.h
-%{_includedir}/wx-%{ver2}/wx/txtstrm.h
-%{_includedir}/wx-%{ver2}/wx/types.h
-%{_includedir}/wx-%{ver2}/wx/uri.h
-%{_includedir}/wx-%{ver2}/wx/utils.h
-%{_includedir}/wx-%{ver2}/wx/variant.h
-%{_includedir}/wx-%{ver2}/wx/vector.h
-%{_includedir}/wx-%{ver2}/wx/version.h
-%{_includedir}/wx-%{ver2}/wx/volume.h
-%{_includedir}/wx-%{ver2}/wx/wfstream.h
-%{_includedir}/wx-%{ver2}/wx/wx.h
-%{_includedir}/wx-%{ver2}/wx/wxchar.h
-%{_includedir}/wx-%{ver2}/wx/wxprec.h
-%{_includedir}/wx-%{ver2}/wx/xti.h
-%{_includedir}/wx-%{ver2}/wx/xtistrm.h
-%{_includedir}/wx-%{ver2}/wx/zipstrm.h
-%{_includedir}/wx-%{ver2}/wx/zstream.h
-%{_includedir}/wx-%{ver2}/wx/fs_inet.h
-%{_includedir}/wx-%{ver2}/wx/gsocket.h
-%{_includedir}/wx-%{ver2}/wx/protocol/file.h
-%{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
-%{_includedir}/wx-%{ver2}/wx/protocol/http.h
-%{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
-%{_includedir}/wx-%{ver2}/wx/sckaddr.h
-%{_includedir}/wx-%{ver2}/wx/sckipc.h
-%{_includedir}/wx-%{ver2}/wx/sckstrm.h
-%{_includedir}/wx-%{ver2}/wx/socket.h
-%{_includedir}/wx-%{ver2}/wx/url.h
-%{_includedir}/wx-%{ver2}/wx/xml/xml.h
-%{_includedir}/wx-%{ver2}/wx/xtixml.h
-%{_includedir}/wx-%{ver2}/wx/db.h
-%{_includedir}/wx-%{ver2}/wx/dbkeyg.h
-%{_includedir}/wx-%{ver2}/wx/dbtable.h
-%{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
-%{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
-%{_includedir}/wx-%{ver2}/wx/unix/execute.h
-%{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
-%{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
-%{_includedir}/wx-%{ver2}/wx/unix/pipe.h
-%{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
-%{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
 EOF
 # --- wxBase headers list ends here ---
 
+# --- wxBase headers list with paths ---
+sed -e 's@^@%{_includedir}/wx-%{ver2}/@' wxbase-headers.files > wxbase-headers.paths
+
+
 # temporarily remove base headers
 mkdir $RPM_BUILD_ROOT/_save_dir
 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
@@ -512,9 +392,11 @@ find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROO
 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
 rm -rf $RPM_BUILD_ROOT/_save_dir
 
-# contrib stuff:
-(cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
-(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
+# utils:
+(cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
+
+# wx-config link is created during package installation, remove it for now
+rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -566,58 +448,52 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %postun gl
 /sbin/ldconfig
 
-%post contrib
-/sbin/ldconfig
-
-%postun contrib
-/sbin/ldconfig
-
-%post contrib-devel
-/sbin/ldconfig
-
-%postun contrib-devel
-/sbin/ldconfig
-
 %files
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
-%endif
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
+%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
 
 %files -n wx-i18n
 %defattr(-,root,root)
-%{_datadir}/locale/*/*/*
+%{_datadir}/locale/*/LC_MESSAGES/*.mo
 
 %files devel -f core-headers.files
 %defattr(-,root,root)
 # shared libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
-%endif
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
+%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
 # static libs
 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
-%if !%{unicode}
-    %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
-%endif
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_propgrid-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_ribbon-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
+%{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
 %dir %{_libdir}/wx
 %{_libdir}/wx/config/%{wxconfig}
@@ -638,65 +514,11 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %if %{unicode}
     %{_libdir}/libwxregexu-%{ver2}.a
 %endif
+%{_libdir}/libwxscintilla-%{ver2}.a
 %dir %{_libdir}/wx
-%{_libdir}/wx/config/%{wxbaseconfig}
-%{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
-%{_libdir}/wx/config/%{wxbaseconfigstatic}
-%{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
 %{_datadir}/aclocal/*.m4
+%{_datadir}/bakefile/presets/*
 
 %files gl
 %defattr(-,root,root)
 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
-
-%files contrib
-%defattr(-,root,root)
-%{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
-%{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
-
-%files contrib-devel
-%defattr(-,root,root)
-%dir %{_includedir}/wx-%{ver2}/wx/animate
-%{_includedir}/wx-%{ver2}/wx/animate/*
-%{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/deprecated
-%{_includedir}/wx-%{ver2}/wx/deprecated/*
-%{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/fl
-%{_includedir}/wx-%{ver2}/wx/fl/*
-%{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/gizmos
-%{_includedir}/wx-%{ver2}/wx/gizmos/*
-%{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
-%{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/mmedia
-%{_includedir}/wx-%{ver2}/wx/mmedia/*
-%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/ogl
-%{_includedir}/wx-%{ver2}/wx/ogl/*
-%{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/plot
-%{_includedir}/wx-%{ver2}/wx/plot/*
-%{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/stc
-%{_includedir}/wx-%{ver2}/wx/stc/*
-%{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
-
-%dir %{_includedir}/wx-%{ver2}/wx/svg
-%{_includedir}/wx-%{ver2}/wx/svg/*
-%{_libdir}/libwx_%{buildname}_svg-%{ver2}.so