%define pref /usr
-%define ver 2.3.0
+%define ver 2.3.2
+%define ver2 2.3
%define rel 0
Summary: The GTK+ 1.2 port of the wxWindows library
Release: %{rel}
Copyright: wxWindows Licence
Group: X11/Libraries
-Source: wxGTK-%{ver}.tar.gz
-URL: http://wxwindows.org
+Source: wxGTK-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
Packager: Vadim Zeitlin <vadim@wxwindows.org>
Prefix: %{pref}
BuildRoot: /var/tmp/%{name}-root
# all packages providing an implementation of wxWindows library (regardless of
# the toolkit used) should provide the (virtual) wxwin package, this makes it
-# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
Provides: wxwin
# in addition, we should provide libwx_gtk as automatic generator only notices
# libwx_gtk-%{ver}-%{rel}
Provides: libwx_gtk.so
-Provides: libwx_gtk-2.2.so
+Provides: libwx_gtk-%{ver2}.so
%description
wxWindows is a free C++ library for cross-platform GUI development.
%prep
%setup -n wxGTK-%{ver}
-./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
+./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
%build
if [ "$SMP" != "" ]; then
/sbin/ldconfig
%files
-%defattr (644, root, root, 755)
+%defattr(-, root, root)
%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
%dir %{pref}/share/wx
%{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk.*
-%attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
+%attr(755, root, root) %{pref}/lib/libwx_gtk-%{ver2}.*
%files devel
-%defattr (644, root, root, 755)
+%defattr(-,root,root)
%dir %{pref}/include/wx
%{pref}/include/wx/*
%dir %{pref}/lib/wx
%{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wxgtk-config
-%attr(755, -, -) %{pref}/bin/wx-config
+%attr(755, root, root) %{pref}/bin/wxgtk-%{ver2}-config
+%attr(755, root, root) %{pref}/bin/wx-config
%files gl
-%attr(755, -, -) %{pref}/lib/libwx_gtk_gl*
+%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
+
+