+# Remove headers that are part of wx-base-devel:
+
+# --- wxBase headers list begins here ---
+cat <<EOF >wxbase-headers.files
+wx/afterstd.h
+wx/any.h
+wx/anystr.h
+wx/app.h
+wx/apptrait.h
+wx/archive.h
+wx/arrimpl.cpp
+wx/arrstr.h
+wx/atomic.h
+wx/base64.h
+wx/beforestd.h
+wx/buffer.h
+wx/build.h
+wx/chartype.h
+wx/checkeddelete.h
+wx/chkconf.h
+wx/clntdata.h
+wx/cmdargs.h
+wx/cmdline.h
+wx/confbase.h
+wx/config.h
+wx/convauto.h
+wx/containr.h
+wx/cpp.h
+wx/crt.h
+wx/datetime.h
+wx/datstrm.h
+wx/dde.h
+wx/debug.h
+wx/defs.h
+wx/dir.h
+wx/dlimpexp.h
+wx/dlist.h
+wx/dynarray.h
+wx/dynlib.h
+wx/dynload.h
+wx/encconv.h
+wx/event.h
+wx/eventfilter.h
+wx/evtloop.h
+wx/except.h
+wx/features.h
+wx/flags.h
+wx/ffile.h
+wx/file.h
+wx/fileconf.h
+wx/filefn.h
+wx/filename.h
+wx/filesys.h
+wx/fontenc.h
+wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
+wx/fs_mem.h
+wx/fs_zip.h
+wx/hash.h
+wx/hashmap.h
+wx/hashset.h
+wx/html/forcelnk.h
+wx/iconloc.h
+wx/init.h
+wx/intl.h
+wx/iosfwrap.h
+wx/ioswrap.h
+wx/ipc.h
+wx/ipcbase.h
+wx/kbdstate.h
+wx/language.h
+wx/link.h
+wx/list.h
+wx/listimpl.cpp
+wx/log.h
+wx/longlong.h
+wx/math.h
+wx/memconf.h
+wx/memory.h
+wx/memtext.h
+wx/mimetype.h
+wx/module.h
+wx/mousestate.h
+wx/msgout.h
+wx/msgqueue.h
+wx/mstream.h
+wx/numformatter.h
+wx/object.h
+wx/platform.h
+wx/platinfo.h
+wx/power.h
+wx/process.h
+wx/ptr_scpd.h
+wx/ptr_shrd.h
+wx/recguard.h
+wx/regex.h
+wx/rtti.h
+wx/scopedarray.h
+wx/scopedptr.h
+wx/scopeguard.h
+wx/sharedptr.h
+wx/snglinst.h
+wx/sstream.h
+wx/stack.h
+wx/stackwalk.h
+wx/stdpaths.h
+wx/stdstream.h
+wx/stockitem.h
+wx/stopwatch.h
+wx/strconv.h
+wx/stream.h
+wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
+wx/sysopt.h
+wx/tarstrm.h
+wx/textbuf.h
+wx/textfile.h
+wx/thread.h
+wx/thrimpl.cpp
+wx/time.h
+wx/timer.h
+wx/tls.h
+wx/tokenzr.h
+wx/tracker.h
+wx/translation.h
+wx/txtstrm.h
+wx/typeinfo.h
+wx/types.h
+wx/unichar.h
+wx/uri.h
+wx/ustring.h
+wx/utils.h
+wx/variant.h
+wx/vector.h
+wx/version.h
+wx/versioninfo.h
+wx/volume.h
+wx/weakref.h
+wx/wfstream.h
+wx/wx.h
+wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
+wx/wxprec.h
+wx/xlocale.h
+wx/xti.h
+wx/xti2.h
+wx/xtistrm.h
+wx/xtictor.h
+wx/xtihandler.h
+wx/xtiprop.h
+wx/xtitypes.h
+wx/zipstrm.h
+wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/implicitconversion.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/meta/pod.h
+wx/fswatcher.h
+wx/generic/fswatcher.h
+wx/unix/app.h
+wx/unix/apptbase.h
+wx/unix/apptrait.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
+wx/unix/evtloopsrc.h
+wx/unix/pipe.h
+wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/tls.h
+wx/unix/fswatcher_kqueue.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/fswatcher_inotify.h
+wx/fs_inet.h
+wx/protocol/file.h
+wx/protocol/ftp.h
+wx/protocol/http.h
+wx/protocol/log.h
+wx/protocol/protocol.h
+wx/sckaddr.h
+wx/sckipc.h
+wx/sckstrm.h
+wx/socket.h
+wx/url.h
+wx/xml/xml.h
+wx/xtixml.h
+EOF
+# --- wxBase headers list ends here ---
+for f in `cat wxbase-headers-list` ; do
+ rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
+done
+
+# list of all core headers:
+find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
+
+# remove wxBase files so that RPM doesn't complain about unpackaged files:
+rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
+rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
+rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*