%define pref /usr
-%define ver 2.3.4
-%define ver2 2.3
+%define ver 2.9.0
+%define ver2 2.9
%define rel 1
Summary: The SciTech MGL port of the wxWindows library
Name: wxMGL
Version: %{ver}
Release: %{rel}
-Copyright: wxWindows Licence
+License: wxWindows Licence
Group: System/Libraries
Source: wxMGL-%{ver}.tar.bz2
URL: http://www.wxwindows.org
mkdir obj-shared
cd obj-shared
-../configure --prefix=%{pref} --enable-soname --with-mgl
+../configure --prefix=%{pref} --with-mgl --disable-fs_inet
$MAKE
cd ..
mkdir obj-static
cd obj-static
-../configure --prefix=%{pref} --disable-shared --with-mgl
+../configure --prefix=%{pref} --disable-shared --with-mgl --disable-fs_inet
$MAKE
cd ..
%postun
/sbin/ldconfig
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
- ln -sf wxmgl-%{ver2}-config %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
- SUM1=`md5sum %{_bindir}/wxmgl-%{ver2}-config | cut -c 0-32`
- SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
- if test "x$SUM1" = "x$SUM2" ; then
- rm -f %{_bindir}/wx-config
- fi
-fi
-
-
%files -f wxstd.lang
%defattr(-,root,root)
%doc COPYING.LIB *.txt
-%dir %{_datadir}/wx
-%{_datadir}/wx/*
%{_libdir}/libwx_mgl*-%{ver2}*.so.*
%files devel
%defattr(-,root,root)
%{_libdir}/libwx_mgl*-%{ver2}*.so
-%dir %{_includedir}/wx
-%{_includedir}/wx/*
+%dir %{_includedir}/wx-*
+%{_includedir}/wx-*/*
%dir %{_libdir}/wx
%{_libdir}/wx/*
%{_bindir}/wxmgl*-config