]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
Committing in .
[wxWidgets.git] / wxGTK.spec
index 13009c2c46f703871c931c0b3174eefa9823a7ea..7e2c946ac8384fa4e53016d5ec156cba1d400f73 100644 (file)
@@ -1,26 +1,50 @@
-Summary: The GTK+ 1.0 port of wxWindows library
+# Note that this is NOT a relocatable package
+%define pref /usr
+%define ver 2.1.11
+%define rel 0
+
+Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
-Version: 2.0.1
-Release: 1
+Version: %{ver}
+Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK2b3.tgz
-URL: http://www.freiburg.linux.de/~wxxt/docs.html
+Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.11.tgz
+URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-Requires: gtk+ >= 1.0.4
+BuildRoot: /tmp/wxgtk_root
+
+# all packages providing an implementation of wxWindows library (regardless of
+# the toolkit used) should provide the (virtual) wxwin package, this makes it
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+Provides: wxwin
 
 %description
-wxWindows is a free C++ library for cross-platform GUI development. With wxWindows, you can create applications for different GUIs from the same source code. This package also contains a dialog editor.
+wxWindows is a free C++ library for cross-platform GUI development.
+With wxWindows, you can create applications for different GUIs (GTK+,
+Motif/LessTif, MS Windows, Mac) from the same source code.
+
+%package devel
+Summary: The GTK+ 1.2 port of the wxWindows library
+Group: X11/Libraries
+Requires: wxGTK
+
+%description devel
+Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
 %setup -n wxGTK
-./configure --prefix=/usr --with-threads
+./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
 
 %build
 make
 
 %install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
@@ -29,11 +53,17 @@ make install
 /sbin/ldconfig
 
 %files
+%defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-/usr/include/wx
-/usr/lib/wx
-/usr/lib/libwx_gtk2.so
-/usr/lib/libwx_gtk2.so.0
-/usr/lib/libwx_gtk2.so.0.1
-/usr/bin/wx-config
+%dir %{pref}/share/wx
+%{pref}/share/wx/*
+%attr(755, -, -) %{pref}/lib/libwx_gtk*
+
+%files devel
+%defattr (644, root, root, 755)
+%dir %{pref}/include/wx
+%{pref}/include/wx/*
+%dir %{pref}/lib/wx
+%{pref}/lib/wx/*
+%attr(755, -, -) %{pref}/bin/wx-config