--enable-sound \
--with-sdl \
--enable-display \
+ --enable-geometry \
+ --enable-graphics_ctx \
--with-libjpeg=sys \
--with-libpng=sys \
--with-libtiff=sys \
-package_gtk_py_lib := python-wxgtk$(release)
+package_gtk_py_lib := python-wxgtk$(release)$(unicode_suffix)
package_gtk_py_ver = python-wxversion
package_gtk_py_tools = python-wxtools
+package_gtk_py_addons = python-wxaddons
package_headers := wx$(release)-headers
package_i18n := wx$(release)-i18n
# The packages listed here are common to all wx versions, and may be provided
# by another source package if more than one is in the release simultaneously.
-common_packages := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools)
+common_packages := $(package_common) $(package_gtk_py_ver) $(package_gtk_py_tools) $(package_gtk_py_addons)
-package_gtk_dbg_py := python-wxgtk$(release)-dbg
+package_gtk_dbg_py := python-wxgtk$(release)$(unicode_suffix)-dbg
-package_msw_dev := libwxmsw$(release)-dev
-package_msw_dbg := libwxmsw$(release)-dbg
+package_msw_dev := libwxmsw$(release)$(unicode_suffix)-dev
+package_msw_dbg := libwxmsw$(release)$(unicode_suffix)-dbg
package_headers_msw := wx$(release)-headers-msw
# The packages listed here will not be built by default.
rm debian/$(package_gtk_py_lib)/$(pydir)/wxversion.py
endif
+
+
install-gtk-py-tools: DH_OPTIONS=-p$(package_gtk_py_tools)
install-gtk-py-tools: install-gtk-py-ver
dh_testdir
rm -r debian/$(package_gtk_py_lib)/usr/bin
-install-gtk-py: install-gtk-py-tools
+install-gtk-py-addons: DH_OPTIONS=-p$(package_gtk_py_addons)
+install-gtk-py-addons: install-gtk-py-tools
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ifndef DEBIAN_WX_DEFAULT_VERSION
+
+ dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) $(pydir)/wxaddons
+else
+ rm -r debian/$(package_gtk_py_lib)/$(pydir)/wxaddons
+endif
+
+
+install-gtk-py: install-gtk-py-addons
install-common: DH_OPTIONS=-p$(package_common)
dh_testroot
dh_clean -k
- dh_install $(objdir_gtk_install)/share/aclocal usr/share
+ dh_install $(objdir_gtk_install)/share/bakefile/presets usr/share/bakefile
+ dh_install $(objdir_gtk_install)/share/bakefile/presets/wx*.bkl usr/share/bakefile/presets
+
+ dh_install $(objdir_gtk_install)/share/aclocal usr/share
dh_installman debian/wx-config.1
- dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
+ dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
dh_installman debian/wxrc-tools.1
dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrc.1
fi
dh_installdeb
- dh_shlibdeps -ldebian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
+ dh_shlibdeps -ldebian/$(package_wxbase_lib)/usr/lib:debian/$(package_wxbase_dbg)/usr/lib:debian/$(package_gtk_lib)/usr/lib:debian/$(package_gtk_dbg)/usr/lib
dh_gencontrol
dh_md5sums
dh_builddeb