# Note that this is NOT a relocatable package
%define pref /usr
-%define ver 2.5.1
+%define ver 2.5.2
%define ver2 2.5
%define rel 1
wx/fontmap.h
wx/fs_mem.h
wx/fs_zip.h
-wx/gzstream.h
wx/hash.h
wx/hashmap.h
wx/hashset.h
EOF
# --- wxBase headers list ends here ---
for f in `cat wxbase-headers-list` ; do
- rm -f $RPM_BUILD_ROOT%{_includedir}/$f
+ rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
done
# list of all core headers:
%postun gl
/sbin/ldconfig
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
- ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
- SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
- SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
- if test "x$SUM1" = "x$SUM2" ; then
- rm -f %{_bindir}/wx-config
- fi
-fi
-
%files
%defattr(-,root,root)