]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
corrections for Mac OS X
[wxWidgets.git] / wxGTK.spec
index 40f00540ea65ceee7ae561fa9dc4f84c02e928f8..cddf2d7d32d49a6ec254daac88425d19b6835f55 100644 (file)
@@ -1,7 +1,6 @@
-# Note that this is NOT a relocatable package
 %define pref /usr
 %define ver 2.3.0
-%define rel 0
+%define rel 1
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -9,15 +8,22 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: wxGTK-%{ver}.tgz
+Source: wxGTK-%{ver}.tar.gz
 URL: http://wxwindows.org
-Packager: Robert Roebling <robert@roebling.de>
+Packager: Vadim Zeitlin <vadim@wxwindows.org>
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
 Provides: wxwin
 
+# in addition, we should provide libwx_gtk as automatic generator only notices
+# libwx_gtk-%{ver}-%{rel}
+Provides: libwx_gtk.so
+Provides: libwx_gtk-2.2.so
+
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
@@ -40,7 +46,7 @@ Requires: wxGTK
 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
-%setup -n wxGTK
+%setup -n wxGTK-%{ver}
 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
@@ -52,7 +58,8 @@ fi
 $MAKE
 
 %install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
 
 %post
 /sbin/ldconfig
@@ -61,6 +68,7 @@ make install
 /sbin/ldconfig
 
 %files
+%defattr (-, root, root)
 %defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
 %dir %{pref}/share/wx
@@ -69,13 +77,14 @@ make install
 %attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
 
 %files devel
+%defattr (-, root, root)
 %defattr (644, root, root, 755)
 %dir %{pref}/include/wx
 %{pref}/include/wx/*
 %dir %{pref}/lib/wx
 %{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wxgtk-config
-%attr(755, -, -) %{pref}/bin/wx-config
+%attr(755, root, root) %{pref}/bin/wxgtk-config
+%attr(755, root, root) %{pref}/bin/wx-config
 
 %files gl
-%attr(755, -, -) %{pref}/lib/libwx_gtk_gl*
+%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*