]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
fix for GTK+ version check caching (now it actually works)
[wxWidgets.git] / wxGTK.spec
index 40f00540ea65ceee7ae561fa9dc4f84c02e928f8..bbf85644ad6c9d849aa84573aae24b9d84a0527d 100644 (file)
@@ -1,7 +1,6 @@
-# Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.3.0
-%define rel 0
+%define ver 2.3.1
+%define rel 1
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -9,15 +8,22 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: wxGTK-%{ver}.tgz
-URL: http://wxwindows.org
-Packager: Robert Roebling <robert@roebling.de>
+Source: wxGTK-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
+Packager: Vadim Zeitlin <vadim@wxwindows.org>
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
 Provides: wxwin
 
+# in addition, we should provide libwx_gtk as automatic generator only notices
+# libwx_gtk-%{ver}-%{rel}
+Provides: libwx_gtk.so
+Provides: libwx_gtk-2.3.so
+
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
@@ -40,7 +46,7 @@ Requires: wxGTK
 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
-%setup -n wxGTK
+%setup -n wxGTK-%{ver}
 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
@@ -52,7 +58,8 @@ fi
 $MAKE
 
 %install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
 
 %post
 /sbin/ldconfig
@@ -61,21 +68,23 @@ make install
 /sbin/ldconfig
 
 %files
-%defattr (644, root, root, 755)
+%defattr(-, root, root)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
 %dir %{pref}/share/wx
 %{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk.*
-%attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
+%attr(755, root, root) %{pref}/lib/libwx_gtk.*
+%attr(755, root, root) %{pref}/lib/libwx_gtk-2.3.*
 
 %files devel
-%defattr (644, root, root, 755)
+%defattr(-,root,root)
 %dir %{pref}/include/wx
 %{pref}/include/wx/*
 %dir %{pref}/lib/wx
 %{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wxgtk-config
-%attr(755, -, -) %{pref}/bin/wx-config
+%attr(755, root, root) %{pref}/bin/wxgtk-config
+%attr(755, root, root) %{pref}/bin/wx-config
 
 %files gl
-%attr(755, -, -) %{pref}/lib/libwx_gtk_gl*
+%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
+
+