]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
patch for cleanall target in mingw makefiles (which I forgot to commit before)
[wxWidgets.git] / wxGTK.spec
index d126784a6c05196591fc1508de4b4e4cc7517543..cddf2d7d32d49a6ec254daac88425d19b6835f55 100644 (file)
@@ -1,7 +1,6 @@
-# Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.1.14
-%define rel 0
+%define ver 2.3.0
+%define rel 1
 
 Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
@@ -10,15 +9,21 @@ Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
 Source: wxGTK-%{ver}.tar.gz
-URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
-Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-BuildRoot: /tmp/wxgtk_root
+URL: http://wxwindows.org
+Packager: Vadim Zeitlin <vadim@wxwindows.org>
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
 Provides: wxwin
 
+# in addition, we should provide libwx_gtk as automatic generator only notices
+# libwx_gtk-%{ver}-%{rel}
+Provides: libwx_gtk.so
+Provides: libwx_gtk-2.2.so
+
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
@@ -30,11 +35,19 @@ Group: X11/Libraries
 Requires: wxGTK
 
 %description devel
-Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
+Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package gl
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Group: X11/Libraries
+Requires: wxGTK
+
+%description gl
+OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
-%setup -n wxGTK
-./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
+%setup -n wxGTK-%{ver}
+./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
 if [ "$SMP" != "" ]; then
@@ -48,9 +61,6 @@ $MAKE
 rm -rf $RPM_BUILD_ROOT
 make prefix=$RPM_BUILD_ROOT%{pref} install
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %post
 /sbin/ldconfig
 
@@ -58,17 +68,23 @@ rm -rf $RPM_BUILD_ROOT
 /sbin/ldconfig
 
 %files
+%defattr (-, root, root)
 %defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
 %dir %{pref}/share/wx
 %{pref}/share/wx/*
-%attr(755, -, -) %{pref}/lib/libwx_gtk*
+%attr(755, -, -) %{pref}/lib/libwx_gtk.*
+%attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
 
 %files devel
+%defattr (-, root, root)
 %defattr (644, root, root, 755)
 %dir %{pref}/include/wx
 %{pref}/include/wx/*
 %dir %{pref}/lib/wx
 %{pref}/lib/wx/*
-%attr(755, -, -) %{pref}/bin/wx-config
+%attr(755, root, root) %{pref}/bin/wxgtk-config
+%attr(755, root, root) %{pref}/bin/wx-config
 
+%files gl
+%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*