]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
fixed wxScrolledWindow::SetScrollbars() which was broken by the virtual size changes
[wxWidgets.git] / wxGTK.spec
index 2b5eefe390935e2a05feca6e39e155e05c0a3e96..a979aaaa88027e606abb7c8506dcd2e8bebe7967 100644 (file)
@@ -1,5 +1,6 @@
 %define pref /usr
-%define ver 2.3.0
+%define ver 2.3.2
+%define ver2 2.3
 %define rel 1
 
 Summary: The GTK+ 1.2 port of the wxWindows library
@@ -8,21 +9,21 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: wxGTK-%{ver}.tar.gz
-URL: http://wxwindows.org
+Source: wxGTK-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
 Packager: Vadim Zeitlin <vadim@wxwindows.org>
 Prefix: %{pref}
 BuildRoot: /var/tmp/%{name}-root
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
-# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
+# possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
 Provides: wxwin
 
 # in addition, we should provide libwx_gtk as automatic generator only notices
 # libwx_gtk-%{ver}-%{rel}
 Provides: libwx_gtk.so
-Provides: libwx_gtk-2.3.so
+Provides: libwx_gtk-%{ver2}.so
 
 %description
 wxWindows is a free C++ library for cross-platform GUI development.
@@ -32,22 +33,28 @@ Motif/LessTif, MS Windows, Mac) from the same source code.
 %package devel
 Summary: The GTK+ 1.2 port of the wxWindows library
 Group: X11/Libraries
-Requires: wxGTK
+Requires: wxGTK = %{ver}
 
 %description devel
 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %package gl
-Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
+Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
 Group: X11/Libraries
-Requires: wxGTK
+Requires: wxGTK = %{ver}
 
 %description gl
-OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
+
+%package static
+Summary: wxGTK static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
 
 %prep
 %setup -n wxGTK-%{ver}
-./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
 
 %build
 if [ "$SMP" != "" ]; then
@@ -55,11 +62,28 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
+$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
 $MAKE
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
@@ -67,24 +91,50 @@ make prefix=$RPM_BUILD_ROOT%{pref} install
 %postun
 /sbin/ldconfig
 
-%files
-%defattr(-, root, root)
-%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-%dir %{pref}/share/wx
-%{pref}/share/wx/*
-%attr(755, root, root) %{pref}/lib/libwx_gtk.*
-%attr(755, root, root) %{pref}/lib/libwx_gtk-2.3.*
+%post gl
+/sbin/ldconfig
+
+%postun gl
+/sbin/ldconfig
+
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+    ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+  SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
+  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+  if test "x$SUM1" = "x$SUM2" ; then
+    rm -f %{_bindir}/wx-config
+  fi
+fi
+
+
+%files -f wxstd.lang
+%defattr(-,root,root)
+%doc COPYING.LIB *.txt
+%dir %{_datadir}/wx
+%{_datadir}/wx/*
+%{_libdir}/libwx_gtk-%{ver2}*.so.*
 
 %files devel
 %defattr(-,root,root)
-%dir %{pref}/include/wx
-%{pref}/include/wx/*
-%dir %{pref}/lib/wx
-%{pref}/lib/wx/*
-%attr(755, root, root) %{pref}/bin/wxgtk-config
-%attr(755, root, root) %{pref}/bin/wx-config
+%{_libdir}/libwx_gtk-%{ver2}*.so
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxgtk-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
 %files gl
-%attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
-
+%defattr(-,root,root)
+%{_libdir}/libwx_gtk_gl*
 
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a