]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
gcc warning about printf() format mismatch corrected
[wxWidgets.git] / wxGTK.spec
index c88d82b05ed38efe313dcabe8ad64bc36bf98d8b..19682dac185a66266ca78c7ea3c424f0d4860cd2 100644 (file)
@@ -1,13 +1,18 @@
-Summary: The GTK+ 1.2 port of wxWindows library
+# Note that this is NOT a relocatable package
+%define pref /usr
+%define ver 2.1.10
+%define rel 0
+
+Summary: The GTK+ 1.2 port of the wxWindows library
 Name: wxGTK
-Version: 2.1.0
-Release: 1
+Version: %{ver}
+Release: %{rel}
 Copyright: wxWindows Licence
 Group: X11/Libraries
-Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK21b.tgz
-URL: http://www.freiburg.linux.de/~wxxt/docs.html
+Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxGTK-2.1.10.tgz
+URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
-Requires: gtk+ >= 1.2.0
+BuildRoot: /tmp/wxgtk_root
 
 # all packages providing an implementation of wxWindows library (regardless of
 # the toolkit used) should provide the (virtual) wxwin package, this makes it
@@ -18,17 +23,28 @@ Provides: wxwin
 wxWindows is a free C++ library for cross-platform GUI development.
 With wxWindows, you can create applications for different GUIs (GTK+,
 Motif/LessTif, MS Windows, Mac) from the same source code.
-This package also contains a dialog editor.
+
+%package devel
+Summary: The GTK+ 1.2 port of the wxWindows library
+Group: X11/Libraries
+Requires: wxGTK
+
+%description devel
+Header files for the wxGTK, the GTK+ 1.2 port of the wxWindows library.
 
 %prep
 %setup -n wxGTK
-./configure --prefix=/usr --with-threads
+./configure --prefix=%{pref} --enable-threads --disable-std_iostreams --disable-newgrid
 
 %build
 make
 
 %install
-make install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT%{pref} install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/ldconfig
@@ -37,11 +53,17 @@ make install
 /sbin/ldconfig
 
 %files
+%defattr (644, root, root, 755)
 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-/usr/include/wx
-/usr/lib/wx
-/usr/lib/libwx_gtk2.so
-/usr/lib/libwx_gtk2.so.1
-/usr/lib/libwx_gtk2.so.1.0
-/usr/bin/wx-config
+%dir %{pref}/share/wx
+%{pref}/share/wx/*
+%attr(755, -, -) %{pref}/lib/libwx_gtk*
+
+%files devel
+%defattr (644, root, root, 755)
+%dir %{pref}/include/wx
+%{pref}/include/wx/*
+%dir %{pref}/lib/wx
+%{pref}/lib/wx/*
+%attr(755, -, -) %{pref}/bin/wx-config