X-Git-Url: https://git.saurik.com/wxWidgets.git/blobdiff_plain/32037c4ed95668dc9422efcfb06013a5de31e673..62fa9712a0865b11e82b7dff6f0305d66bb6b98e:/wxBase.spec

diff --git a/wxBase.spec b/wxBase.spec
index 938201a416..5b38f95a9b 100644
--- a/wxBase.spec
+++ b/wxBase.spec
@@ -27,14 +27,20 @@ the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
 %package devel
 Summary: wxBase headers needed for developping with wxBase
 Group: Development/Libraries
-Requires: wxBase
+Requires: wxBase = %{ver}
 
 %description devel
 Header files for wxBase. You need them to develop programs using wxBase.
 
+%package static
+Summary: wxBase static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxBase. You need them if you want to link statically against wxBase.
+
 %prep
 %setup -n wxBase-%{ver}
-./configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
 
 %build
 if [ "$SMP" != "" ]; then
@@ -42,12 +48,25 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
 $MAKE
-(cd locale; make allmo)
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
+$MAKE
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -74,11 +93,10 @@ if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
   fi
 fi
 
-%files
+%files -f wxstd.lang
 %defattr (-,root,root)
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_base*so.*
-%{_datadir}/locale/*/*/*.mo
 
 %files devel
 %defattr (-,root,root)
@@ -88,4 +106,8 @@ fi
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
 %{_bindir}/wxbase-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a