]> git.saurik.com Git - wxWidgets.git/blobdiff - debian/rules
Corrected InsertColumnItem name
[wxWidgets.git] / debian / rules
index 22015de76176cf166114b8d204e3296f91e38e86..c51f6776c16c44efdee4fde97c42247e24b37e7c 100755 (executable)
@@ -42,6 +42,9 @@ release   := $(shell dpkg-parsechangelog | sed -n 's/^Source: wxwidgets//p')
 soversion := $(shell grep '^WX_CURRENT=' configure.in | sed 's/WX_CURRENT=\([0-9]\+\).*/\1/')
 sorelease := $(release:%-$(DEBIAN_WXFLAVOUR)=%).$(soversion)$(addprefix -,$(DEBIAN_WXFLAVOUR))
 
+pydir     := usr/lib/$(python_ver)/site-packages
+wxpydir   := $(pydir)/wx-$(sorelease)-gtk2-unicode
+
 cross_host  = i586-mingw32msvc
 cross_build = $(shell ./config.guess)
 
@@ -121,8 +124,8 @@ install_all_native = $(install_all_arch) $(install_all_indep)
 install_all = $(install_all_native) $(install_all_cross)
 
 
-wxconfig     := $(shell pwd)/$(objdir_gtk_shared)/wx-config
-wxconfig-dbg := $(shell pwd)/$(objdir_gtk_debug)/wx-config
+wxconfig     := $(shell pwd)/$(objdir_gtk_shared)/wx-config --no_rpath
+wxconfig-dbg := $(shell pwd)/$(objdir_gtk_debug)/wx-config --no_rpath
 
 #contrib_libs := $(subst CVS,,$(notdir $(wildcard contrib/include/wx/*)))
 
@@ -150,7 +153,10 @@ control-files-stamp: debian/control
        done;
        @for f in docs postinst prerm; do                                    \
                echo "generating control file $(package_gtk_py_lib).$$f";    \
-               sed -e 's/=PY/$(python_ver)/g;s/=V/$(release)/g;s/=SOV/$(sorelease)/g' \
+               sed -e 's/=PY/$(python_ver)/g;                               \
+                       s|=WXPYDIR|$(wxpydir)|g;                             \
+                       s/=V/$(release)/g;                                   \
+                       s/=SOV/$(sorelease)/g'                               \
                        < debian/libwxgtk-python.$$f                         \
                        > debian/$(package_gtk_py_lib).$$f;                  \
        done;
@@ -213,13 +219,13 @@ configure-gtk-shared-stamp:
                                --cache-file=$(config_cache)            \
                                --with-flavour=$(DEBIAN_WXFLAVOUR)      \
                                --with-gtk                              \
-                               --enable-gtk2                           \
                                --enable-unicode                        \
                                --with-opengl                           \
                                --with-zlib=sys                         \
                                --with-libjpeg=sys                      \
                                --with-libpng=sys                       \
                                --with-libtiff=sys                      \
+                               --with-gnomeprint                       \
                                --enable-dynamic-loader                 \
                                --enable-std_iostreams
        touch $@
@@ -237,7 +243,6 @@ configure-gtk-static-stamp:
                                --cache-file=$(config_cache)            \
                                --with-flavour=$(DEBIAN_WXFLAVOUR)      \
                                --with-gtk                              \
-                               --enable-gtk2                           \
                                --enable-unicode                        \
                                --with-opengl                           \
                                --disable-shared                        \
@@ -245,6 +250,7 @@ configure-gtk-static-stamp:
                                --with-libjpeg=sys                      \
                                --with-libpng=sys                       \
                                --with-libtiff=sys                      \
+                               --with-gnomeprint                       \
                                --enable-dynamic-loader                 \
                                --enable-std_iostreams
        touch $@
@@ -262,7 +268,6 @@ configure-gtk-debug-stamp:
                                --cache-file=$(config_cache)            \
                                --with-flavour=$(DEBIAN_WXFLAVOUR)      \
                                --with-gtk                              \
-                               --enable-gtk2                           \
                                --enable-unicode                        \
                                --with-opengl                           \
                                --enable-debug                          \
@@ -270,6 +275,7 @@ configure-gtk-debug-stamp:
                                --with-libjpeg=sys                      \
                                --with-libpng=sys                       \
                                --with-libtiff=sys                      \
+                               --with-gnomeprint                       \
                                --enable-dynamic-loader                 \
                                --enable-std_iostreams
        touch $@
@@ -528,11 +534,10 @@ install-gtk-py-lib: build-gtk-py-stamp
                              UNICODE=1                                         \
                              FLAVOUR=$(DEBIAN_WXFLAVOUR)
 
-       find debian/$(package_gtk_py_lib)/usr/lib/$(python_ver)/site-packages   \
-               -name '*.py?' -exec rm '{}' ';'
+       find debian/$(package_gtk_py_lib)/$(pydir) -name '*.py?' -exec rm '{}' ';'
 
        # This is rather bogus, its included in the main copyright file now though.
-       rm -f debian/$(package_gtk_py_lib)/usr/lib/$(python_ver)/site-packages/wx-$(sorelease)/wx/tools/XRCed/license.txt
+       rm -f debian/$(package_gtk_py_lib)/$(wxpydir)/wx/tools/XRCed/license.txt
 
 install-gtk-py: DH_OPTIONS=-p$(package_gtk_py)
 install-gtk-py: install-gtk-py-lib
@@ -541,9 +546,9 @@ install-gtk-py: install-gtk-py-lib
        dh_clean -k
        dh_installdirs
 
-       dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) usr/bin           \
-               usr/lib/$(python_ver)/site-packages/wxversion.py                \
-               usr/lib/$(python_ver)/site-packages/wx.pth
+       dh_movefiles --sourcedir=debian/$(package_gtk_py_lib)                   \
+               usr/bin                                                         \
+               $(pydir)/{wxversion.py,wx.pth}
        rm -r debian/$(package_gtk_py_lib)/usr/bin
 
        dh_installman debian/wxPython-tools.1
@@ -556,7 +561,8 @@ install-gtk-py: install-gtk-py-lib
                usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/helpviewer.1 \
                usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalacarte.1 \
                usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalamode.1  \
-               usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywrap.1
+               usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywrap.1     \
+               usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywxrc.1
 
 
 install-common: DH_OPTIONS=-p$(package_common)
@@ -566,9 +572,6 @@ install-common: install-gtk-shared-stamp
        dh_clean -k
        dh_installdirs
 
-#      We don't need the afm metrics for gtk2, but we might need them to support
-#      the 2.4 release for a while still and any other ports we might build.
-       dh_install $(objdir_gtk_install)/share/wx       usr/share
        dh_install $(objdir_gtk_install)/share/aclocal  usr/share
        dh_installman debian/wx-config.1
 
@@ -633,15 +636,11 @@ install-gtk-dbg-py: build-gtk-dbg-py-stamp
                              UNICODE=1                                         \
                              FLAVOUR=$(addsuffix -,$(DEBIAN_WXFLAVOUR))dbg
 
-       find debian/$(package_gtk_dbg_py)/usr/lib/$(python_ver)/site-packages   \
-               -name '*.py?' -exec rm '{}' ';'
-
-       rm -rf usr/bin                                                          \
-              usr/lib/$(python_ver)/site-packages/wxversion.py                 \
-              usr/lib/$(python_ver)/site-packages/wx.pth
+       find debian/$(package_gtk_dbg_py)/$(pydir) -name '*.py?' -exec rm '{}' ';'
+       rm -rf usr/bin $(pydir)/{wxversion.py,wx.pth}
 
        # This is rather bogus, its included in the main copyright file now though.
-       rm -f debian/$(package_gtk_dbg_py)/usr/lib/$(python_ver)/site-packages/wx-$(sorelease)/wx/tools/XRCed/license.txt
+       rm -f debian/$(package_gtk_dbg_py)/$(wxpydir)/wx/tools/XRCed/license.txt
 
 
 install-msw-dev: DH_OPTIONS=-p$(package_msw_dev)