X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/ed9665aedf77b3b8345bd4ed33de7885738e29f0..e977b8b9234ac5db32f2f0ad7e183139b988340d:/debian/tests/run-tests

diff --git a/debian/tests/run-tests b/debian/tests/run-tests
index e03db9b0c..e459d7093 100644
--- a/debian/tests/run-tests
+++ b/debian/tests/run-tests
@@ -2,18 +2,21 @@
 
 set -e
 
-unset LANGUAGE
-export LC_ALL=C
-
 # we need the buildin webserver for the tests
 if [ ! -e environment.mak ]; then
     make startup
 fi
 make -C test/interactive-helper/
 
-# run against the installed apt
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
+APT_INTEGRATION_TESTS_SOURCE_DIR=$(pwd) \
 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
 APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
 APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
+APT_INTEGRATION_TESTS_INTERNAL_SOLVER=/usr/lib/apt/solvers/apt \
+APT_INTEGRATION_TESTS_DUMP_SOLVER=/usr/lib/apt/solvers/dump \
 APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+APT_INTEGRATION_TESTS_LIBRARY_PATH=/dev/null/does/not/exist \
 ./test/integration/run-tests