X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/b574dd1fac99ba71b1d0adf0aa164100fcf0cb91..01f2b54d3606637101a95585994fb6f1e88dab66:/debian/rules

diff --git a/debian/rules b/debian/rules
index dfee44fde..d19531dfc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -125,8 +125,8 @@ build/build-doc-stamp: build/configure-stamp
 clean:
 	dh_testdir
 #	dh_testroot
-	-$(MAKE) clean
-	-$(MAKE) distclean
+	[ -f Makefile ] && $(MAKE) clean
+	[ -f Makefile ] && $(MAKE) distclean
 
 	rm -rf build
 
@@ -185,8 +185,9 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
-apt: build debian/shlibs.local
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc debian/shlibs.local
 	dh_testdir -p$@
 	dh_testroot -p$@
 	dh_clean -p$@ -k
@@ -204,24 +205,29 @@ apt: build debian/shlibs.local
 	find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
 	cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+	# https has its own package
+	rm debian/$@/usr/lib/apt/methods/https
 
 	cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
 	cp -r $(BLD)/locale debian/$@/usr/share/
 
 	cp debian/bugscript debian/$@/usr/share/bug/apt/script
-	cp debian/apt.logrotate debian/$@/etc/logrorate.d/apt
+	cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
 	cp share/debian-archive.gpg debian/$@/usr/share/$@
 	cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #	head -n 500 ChangeLog > debian/ChangeLog
 
+	# copy lintian override
+	cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
 	# make rosetta happy and remove pot files in po/ (but leave stuff
 	# in po/domains/* untouched) and cp *.po into each domain dir
 	rm -f build/po/*.pot
 	rm -f po/*.pot
 
 	dh_installexamples -p$@ $(BLD)/docs/examples/*
-	dh_installman -p$@ 
+	dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
 	dh_installcron -p$@
 	dh_installdocs -p$@
 	dh_installchangelogs -p$@
@@ -264,6 +270,7 @@ libapt-pkg-dev: build debian/shlibs.local
 	dh_md5sums -p$@
 	dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
 	dh_testdir -p$@
 	dh_testroot -p$@
@@ -279,7 +286,7 @@ apt-utils: build debian/shlibs.local
 	dh_installexamples -p$@
 
 	# Install the man pages..
-	dh_installman -p$@
+	dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
 	dh_installchangelogs -p$@
 	dh_strip -p$@
@@ -292,7 +299,7 @@ apt-utils: build debian/shlibs.local
 	dh_md5sums -p$@
 	dh_builddeb -p$@
 
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
 	dh_testdir -p$@
 	dh_testroot -p$@
 	dh_clean -p$@ -k
@@ -300,9 +307,9 @@ apt-transport-https: build debian/shlibs.local
 
 	# install the method
 	mkdir -p debian/$@/usr/lib/apt/methods
-	mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+	cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
 
-	dh_installdocs -p$@
+	dh_installdocs -p$@ debian/apt-transport-https.README
 	dh_installexamples -p$@
 
 	# Install the man pages..