X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/aa16679ccb39598b9b4546c912af1cf8c70e529b..8e5d47a3a4e735835498574a58e0a33de04a0377:/debian/apt.postinst

diff --git a/debian/apt.postinst b/debian/apt.postinst
index df0433057..4d87c4e25 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -15,11 +15,12 @@ set -e
 
 case "$1" in
     configure)
-
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/ubuntu-archive.gpg /etc/apt/trusted.gpg
-        fi
-
+	SECRING='/etc/apt/secring.gpg'
+	# test if secring is an empty normal file
+	if test -f $SECRING -a ! -s $SECRING; then
+		rm -f $SECRING
+	fi
+	apt-key update
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)