X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/976bac7a74f967e8a9cb0927aef72536f85be0ed..60504a4198070671b2c4fe7045564f1d7a228f71:/debian/rules

diff --git a/debian/rules b/debian/rules
index 0862ffbbf..b3222f3b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.47 2003/02/12 14:28:03 doogie Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -14,8 +14,6 @@
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-export DH_COMPAT=2
-
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -29,12 +27,20 @@ endif
 # See below
 -include build/environment.mak
 
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+  export CXXFLAGS = -O0 -g -Wall
+else
+  export CXXFLAGS = -O2 -g -Wall
+endif
+
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild -us -uc
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -53,9 +59,11 @@ endif
 
 # Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
 .PHONY: configure.in
 configure.in:
-	sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+	sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
 else
 configure.in:
 endif
@@ -101,15 +109,7 @@ build/configure-stamp: configure
 	dh_testdir
 	-mkdir build
 	cp COPYING debian/copyright
-ifneq ($(wildcard /usr/share/misc/config.sub),)
-	cp -a /usr/share/misc/config.sub buildlib/config.sub
-	echo Updating buildlib/config.sub
-endif
-ifneq ($(wildcard /usr/share/misc/config.guess),)
-	cp -a /usr/share/misc/config.guess buildlib/config.guess
-	echo Updating buildlib/config.guess
-endif
-	cd build && ../configure $(confflags)
+	cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
 	touch $@
 
 build/build-stamp: build/configure-stamp
@@ -146,15 +146,11 @@ libapt-pkg-doc: build-doc debian/shlibs.local
 	dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
 			    doc/libapt-pkg2_to_3.txt doc/style.txt
-
-	-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-	-cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-
 	dh_installexamples -p$@
 #	dh_installmenu -p$@
 #	dh_installinit -p$@
 #	dh_installcron -p$@
-#	dh_installmanpages -p$@
+#	dh_installman -p$@
 
 #	dh_undocumented -p$@
 	dh_installchangelogs -p$@
@@ -176,12 +172,7 @@ apt-doc: build-doc
 #
 	# Copy the guides
 	dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-	               $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
-	# One or the other..
-	-cp -a debian/apt-doc.dhelp debian/apt/usr/doc/apt-doc/.dhelp
-	-cp -a debian/apt-doc.dhelp debian/apt/usr/share/doc/apt-doc/.dhelp
-
+	               $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
 	dh_installchangelogs -p$@
 	dh_compress -p$@
 	dh_fixperms -p$@
@@ -194,42 +185,53 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev apt-utils 
+binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
 apt: build debian/shlibs.local
 	dh_testdir -p$@
 	dh_testroot -p$@
 	dh_clean -p$@ -k
-	dh_installdirs -p$@ /usr/share
+	dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
 #
 # apt install
 #
-	cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+	cp $(BLD)/bin/apt-* debian/$@/usr/bin/
 
 	# Remove the bits that are in apt-utils
-	rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+	rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
 
 	# install the shared libs
-	find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
-	find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+	find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+	find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
-	cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+	cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
 
-	cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
-	cp -r $(BLD)/locale debian/apt/usr/share/
+	cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+	cp -r $(BLD)/locale debian/$@/usr/share/
 
+	cp debian/bugscript debian/$@/usr/share/bug/apt/script
+	cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
+
+	cp share/debian-archive.gpg debian/$@/usr/share/$@
+	cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #	head -n 500 ChangeLog > debian/ChangeLog
 
-	dh_installexamples -p$@ $(BLD)/docs/examples/*
-	dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
+	# make rosetta happy and remove pot files in po/ (but leave stuff
+	# in po/domains/* untouched) and cp *.po into each domain dir
+	rm -f build/po/*.pot
+	rm -f po/*.pot
 
+	dh_installexamples -p$@ $(BLD)/docs/examples/*
+	dh_installman -p$@ 
+	dh_installcron -p$@
+	dh_installdocs -p$@
 	dh_installchangelogs -p$@
 	dh_strip -p$@
 	dh_compress -p$@
 	dh_fixperms -p$@
+	dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
 	dh_installdeb -p$@
-	dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+	dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
 	dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
-	dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
 	dh_md5sums -p$@
 	dh_builddeb -p$@
 
@@ -250,7 +252,7 @@ libapt-pkg-dev: build debian/shlibs.local
 #	dh_installmenu -p$@
 #	dh_installinit -p$@
 #	dh_installcron -p$@
-#	dh_installmanpages -p$@
+#	dh_installman -p$@
 
 	dh_installchangelogs -p$@
 	dh_strip -p$@
@@ -274,19 +276,45 @@ apt-utils: build debian/shlibs.local
 
 	cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
 	dh_installdocs -p$@
+	dh_installexamples -p$@
 
 	# Install the man pages..
-	mkdir -p debian/$@/usr/share/man/man1
-	-cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+	dh_installman -p$@
 
 	dh_installchangelogs -p$@
 	dh_strip -p$@
 	dh_compress -p$@
 	dh_fixperms -p$@
+	dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
 	dh_installdeb -p$@
-	LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+	dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
 	dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
-	dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+	dh_md5sums -p$@
+	dh_builddeb -p$@
+
+apt-transport-https: build debian/shlibs.local
+	dh_testdir -p$@
+	dh_testroot -p$@
+	dh_clean -p$@ -k
+	dh_installdirs -p$@
+
+	# install the method
+	mkdir -p debian/$@/usr/lib/apt/methods
+	mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+	dh_installdocs -p$@
+	dh_installexamples -p$@
+
+	# Install the man pages..
+	dh_installman -p$@
+
+	dh_installchangelogs -p$@
+	dh_strip -p$@
+	dh_compress -p$@
+	dh_fixperms -p$@
+	dh_installdeb -p$@
+	dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib 
+	dh_gencontrol -p$@
 	dh_md5sums -p$@
 	dh_builddeb -p$@
 
@@ -323,15 +351,23 @@ binary: binary-indep binary-arch
 # edit configure.in
 # debian/rules cvs-build
 
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
 	rm -rf debian/cvs-build
-	cvs update
-	$(MAKE) startup
-	$(MAKE) doc
-	tar c --exclude CVS --exclude cvs-build . |\
-		(mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-	(cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+	mkdir -p debian/cvs-build
+	(cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+	$(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+	(cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
 	-mkdir -p ../upload-$(APT_DEBVER)
 	cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+	rm -rf debian/arch-build
+	mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+	tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+	$(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+	(cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)