X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/7aee90b638490036b8f4244dcb3d14ba0bc6dd8a..d4bb5cc77a8e40656a9767f31c0a12d064c8d305:/debian/apt.postinst

diff --git a/debian/apt.postinst b/debian/apt.postinst
index ae1801198..4d87c4e25 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -15,11 +15,12 @@ set -e
 
 case "$1" in
     configure)
-
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
-        fi
-
+	SECRING='/etc/apt/secring.gpg'
+	# test if secring is an empty normal file
+	if test -f $SECRING -a ! -s $SECRING; then
+		rm -f $SECRING
+	fi
+	apt-key update
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)