X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/4d0818cc39f7c0d44ecdfcdf9701058f81caa492..51818f26c784bb574dafc545e8ae320845e5e8fc:/debian/apt.postinst

diff --git a/debian/apt.postinst b/debian/apt.postinst
index b0a5da7d8..1f98fcece 100755
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -40,9 +40,14 @@ case "$1" in
 	fi
 
 	# add unprivileged user for the apt methods
-	adduser --force-badname --system -home /var/empty \
+	adduser --force-badname --system --home /nonexistent  \
 	    --no-create-home --quiet _apt || true
 
+	# Fixup any mistake in the home directory of the _apt user
+	if dpkg --compare-versions "$2" lt-nl 1.1~exp10~; then
+	    usermod --home /nonexistent _apt
+	fi
+
 	# deal with upgrades from experimental
 	if dpkg --compare-versions "$2" 'eq' '1.1~exp3'; then
 	    # libapt will setup partial/ at runtime